In LO Calc right click causes cut

LO Calc LinuxMint 19.0 - right click on selected cell results in CUT about 10% of time. Then I need to do undo. When it works correctly the context menu pops up with CUT highlighted. So I suspect when it fails the selected CUT is getting selected. Don’t find such a problem reported so I expect I am doing something wrong. Have tried two mice and both fail the same and the problem is only in calc. Have tried to reproduce in writer with no failures. If I go very slow and select a cell, wait a moment, then drag to select a number of cells, wait a moment then right click on menu it fails much less often, but does still fail occasionally.
I have had some success when right clicking do not release button and move cursor to item in menu, then release and left click the item. I didn’t have this problem with 5.2 . Am considering reinstalling old release to see if problem occurs. But what would that buy me? Any ideas, setting I maybe over looking?


could you test in failsafe mode? (see the Help menu)

Build ID:

In Centos Linux 7.7.1908 (Core)
Still doing this behavior, but 80% of the time, not 10%.

The workaround is to press and hold the rmb vs clicking it. This allows you to change the menu selection away from cut and release on copy or paste, etc…

You can also go into Tools menu → Customize… then select the “Context Menus” tab. Select “Cell” menu. Here you can select Cut then the black arrow on the right. This will move cut and put copy to be selected when the RMB is clicked accidently.