In OSX 10.15.5 "Hide Libre Office" fails repeatedly

Happening in LO but it happened in previous version[s] as well. It doesn’t happen all the time, but often enough to be a time waster. As well as being program hostile behavior.

Which functionality are you talking about? Right click -> Hide on LibreOffice icon in macOS Dock pane?

yes, exactly

… and this is a functionality of macOS’s window manager / desktop manager. Hence it is not clear how LibreOffice is involved in this.

actually, I access it another way. should have checked before I answered so blithely. I click on “libre office” next to the apple in the upper left. the 4th item down in the ensuing menu is “hide libre office.” I highlight & click on that. the application then blinks off as if I have been successful, and then in the succeeding moment it returns to the screen as if I had never done so. then I do it again. then it does the same thing. sometimes it takes only 1 or 2 tries to finally hide it. sometimes it can take 6 or 7. even after I completely close libre office and restart, sometime the malbehavior persists.

From my test just now, this is somehow related to setting LibreOffice -> Preferences -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use OpenGL for all rendering. This time disabling this option causes the problem to appear more often, while in almost all other cases, setting this option may cause a problem. So I suggest to test using Option: [x] Use OpenGL for all rendering` for a while (disable as soon as this causes blurry fonts/blurry rendering on your system).

In addition, I never could reproduce the behavior, if using shortcut `CMD+H` (aka `⌘+H`) to hide LibreOffice. Tested using LibreOffice and on macOS 10.15.6 (Catalina).

thank you. I will take a run at it that way.

even with the OGL all rendering option set, the malbehaviopr re-erupted. CMD+H however works every time so far. problem (tentatively) solved. will report back if it somehow unsolves itself.