In the ToC, how can I set a different chapter name from what is in the header?

I have a document with an H1 chapter name “Section 1: Overview” but the ToC must only use the word “Overview”. The H1 paragraph (or some clever alternate elements) must have that text all on one line and the ToC must not have any other text after the chapter number except “Overview” (ie: “1 Overview…”).

Is there any way to configure the ToC system to only either use a part of the H1 name, to only use an alternate name, or is there an alternate text element combination that will display the required text on one line but only designate the “Overview” portion as the text for the H1 element?

I suppose you only type “Overview” (or the chapter title) in your H1 paragraph. The “Section x:” is automatically added by the ToC system, i.e. "Overview " as separator before, ": " as separator after and the number from the desired category (1,2,3, A,B,C, etc.)

  • When you insert your ToC, customise the Level 1 entries in the Insert Index/Table dialog, Entries tab: click on the chapter number item E#. A Format drop-down menu appears below; select Number without separator instead of the default Number.
  • In the box between E# and E, insert a space (because all separators where removed, causing the number and the title to be joined).

You can do the same for other levels.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

If you select E# element in ToC dialog (Entries tab), and choose “Number without separator” format, then it looks like result is what OP needs

@mikekaganski: thanks, I did not know this option; I update my answer

Thank you for your answer. Unfortunately, you did not understand the question. Your supposition that the H1 paragraph text is “Overview” is contrary to what was stated in the OP.

  • The H1 text is “Section 1: Overview”.
  • The desired level 1 ToC text for that H1 paragraph is “1 Overview…”.

Additionally there are more H1 paragraphs like

  • “Section 2: Terms and Definitions”
  • “Section 3: Structure”

… and so on. Those two additional H1 paragraphs should appear in the ToC as

  • “2 Terms and Definitions…”
  • “3 Structure…”

However, you gave me enough to think about that I came up with the answer!

The H1 paragraphs all follow the pattern:

  • “Section N: Chapter Text”

and the ToC entries should be

  • “N Chapter Text…”

The solution is to:

  1. Configure the ToC Hx styles to all use the Outline Level for that header level. Numbering should be “None”.
  2. Configure Tools->Outline Numbering for level 1 as “Heading 1”, decimal digits, "Section " before, and ": " after.
  3. Recreate the H1 paragraphs. They will now display "Section N: " (N starting at 1) after which you can type in the chapter text.
  4. Update the ToC with the default Entries structure and values. It will now pick up only the H1 number and the chapter text. The other text is ignored since it is all part of the Outline Numbering before and after texts. You now get the desired “N Chapter Text…” ToC entries.

Thank you very much for your reply. You might have not solved the problem but you got me thinking more about outline numbering and formatting that led me to the solution.
(BTW: I had no idea you could type static text in between ToC Entries structure elements. That could prove useful in the future. Thx again!)

Hehe… the answer by @ajlittoz references Section x: as added automatically, i.e. being outline numbering. So, your " did not understand the question" and “You might have not solved the problem” only tells about your wrong initial approach, and that answerer assumed correct initial approach (which you didn’t use initially), not wrong understanding.

Possibly, maybe even probably - but, since I had no idea about this “correct initial approach” and it was not explained in the post, it served no purpose. Besides, the whole “editing the ToC Entries” business turns out to be unnecessary since the Outline Numbering can be configured to allow the ToC to correctly pick up the E# number and E text.

I’m just grateful his answer got me thinking in the right direction to create a workable solution.