In Writer, Ctrl+F doesn’t distinguish ' from ’. Straight vs curly apostrophe

Before upgrading to the new Linux Mint 21, LibreOffice Writer was distinguishing the straight apostrophe ’ (U+0027) by the curly, typographic one ’ (U+2019). It was a feature I used to use quite often, as I am a linguist and often when doing revisions of texts, authors copy and paste parts from other texts and don’t bother to keep consistent the use of the apostrophe. Now if I look for a straight one in the text, it shows me all the curly ones. I believe it changed with the new version of Office,, of which I got prompted the update at the first usage of LibreOffice in the newly installed Linux Mint 21.
I don’t know if it is a bug or a wanted feature, I don’t know if it is fixable somehow by the end‑user, but I ask anyway.
Maybe using AutoCorrect, if it works also during a spellcheck? I’ve Never tried.
Well, I tried now, it doesn’t find the ’ bait I put.

While I understand that U+2019 is a single closing quotation mark and not really an apostrophe (but Writer autocorrects any usage of straight apostrophe for this, it’s where I took it from when I coded the keyboard), it should really distinguish it from the straight apostrophe, because U+2019≠U+0027 as much as, for instance, U+007A≠U+0069 (z≠i)


1 Like

Thank you. Let’s just hope it will get fixed soon.