In Writer, how do I restrict a table of contents to one column in a two-column layout?

I have set-up a document with two columns. How do I restrict the Table of Contents to the left column of the first page?

In answer to ajlittoz:

I am using Windows 10, LO Version: (x64), saving in docx format.

Structure of the document is cover page, followed by TOC, followed by chapters. Yes, the document is using Heading 1 styles. (I am very familiar with document templates from Word and Framemaker - I am trying to learn LO.) The problem is the TOC appears to generate its own, single-column section break when I create it, and there doesn’t seem to be a way to change it back to two column.

In answer to floris v:

I want the TOC to start the left column, and have the text of the document start immediately after it on the same page (it’s a short TOC). I have tried reducing width of the TOC, but this doesn’t help because the TOC generates its own section break, which overlays the text in the right column.

You can’t without more information about your document. Edit your question. First, mention OS name, LO version and save format (.odt native or .doc(x) foreign).

Describe the overall structure of the document: cover page, if any, followed by TOC, followed by chapters?

How do you switch from part to part? Usually with a page break but there are several ways to insert such a break and several break “flavours”. Are you familiar with styles? Are your chapter headings styled as expected with Heading n?

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

Don’t save in docx format - LO is much superior to Word when it comes to complex page layout involving page styles. Saving in docx format will spoil everything that LO offers.

I had no problem starting a document with 2 columns, TOC on page 1, column 1, text following below. But that’s in version

Problem is I am collaborating on the document with someone who is using Word. However, let me try updating to

The solution is quite easy in Writer with the help of page styles and parameters of the TOC generator. But this will be damaged as soon as you save .docx because this foreign format has no notion of page styles. It will be converted approximately and as soon as you come back to Writer, parts of the formatting are lost.

If your concern is only the TOC, insert it in its own 1-column page style with appropriate settings from the dialog and customisation of the Contents n paragraph syles. See how it survives .docx conversion.

Hi, ajlittoz. It looks like what you’re saying is: what I am trying to do can’t be done. It’s a pity, but at least it means I can stop wasting time on LO and look for another solution. Thanks for your help. G

More exactly, it can be done when there is no conversion to foreign formats. .docx is known as a poor format with much less expressiveness than ODF. Exporting to .docx (and working with it there after) causes loss of information.

However, you should try formatting your TOC as I suggest. I won’t experiment because I have no use of .docx format. There is a possibility (?) that the output filter converts Writer page styles to Word sections and keeps your formatting. But this can be told only with experimentation.

Two possibilities: You put the TOC on a separate page formatted with a page style with 1 column. Use Insert - More Breaks - Manual Break... to insert a page style break - with it, you can set the page style for the next page. Use it on the page before the TOC page and at the bottom of the TOC page.

Or you reduce the size of the TOC so that it doesn’t wrap to the second column.

To show the community that your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers.

And also adjust the margins so that the text area looks like the first column only.