In Writer when I click above or below the scrollbar it jumps to the place I clicked, can it go up or down by a page?

I have a new install of Ubuntu and Libre Office. This was not a problem in the previous version. I am editing a 600 page document and constantly loosing my place because I automatically expect the typical behaviour of the scrollbar. Drives me nuts. Is it possible to change it somehow? Tried to get used to that, can’t. Search for the answer, couldn’t find. It only works like this in Writer, the Calc behaves in a typical way. Maybe I could install a different version of the Libre office, would that help? I only use touch pad, not a mouse.

Ubuntu 20.04.2 LTS, 64-bit, GNOME 3.36.8
Libre Office Version:
Build ID: 1:6.4.7-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US

Confirming - and also the case in LO 7.1 on Ubuntu with gtk3 plugin. And that seems to be standard on GNOME; e.g., it works the same way with gedit. So likely the VCL plugin just implements proper HIGs.

Maybe you could try using a different environment? I don’t know what KDE thinks about this. I only can tell that on Windows, the “by page” behavior works as expected using 7.1.

Mike, thank you, at least I’m not alone :slight_smile: By a different environment you mean Windows? I only have Ubuntu.

Astur, thanks, I use the arrow keys and page keys, and the chapter structure, but I forget so often that the scroll bar does not work in the way I am used to, click it, and then I have to search for the place I was again and again. Maybe three more days and I will re-learn it, but my movements are so automatic, that I screw the location up every 10 minutes.

By different environment, I meant KDE :slight_smile:

This behaviour comes from GTK+. A system configuration recently changed in the library. As I am not using GNOME, I can’t tell you which file and parameter to tweak to revert to “common” behaviour. “Click and jump to” was the raw X11 behaviour. Widgets built over X11 usually implement page-jump. Try a web search. I remember having done this for GTK-only applications like GRAMPS.

Mike, thanks :slight_smile: Most probably because of my question you now know that I have no clue how to try using a different environment :slight_smile:

ajlittoz, thank you, what you wrote would really lead me to the solution, just I didn’t manage to find what exactly I have to tweak in X11. I did a 20-minute search, learnt a lot of things on the way, but realised I know too little about the structure of how linux is working, so I probably searched to some wrong direction, found nothing I could try. I’m fine with letting it go, that’s probably more than I am able to do, I will manage without a scrollbar :slight_smile:

The issue is not in LO but in the GTK+ library. A recent update changed default settings (or omitted one of them) affecting scrollbar which reverted to the X-Windows behaviour of click-and-jump instead of page up/down.

A query of “gtk+ linux scrollbar configuration” gave several answers, among which this one, a bit old but still valid provided you replace “3.0” with 4.0".

This point to GTK+ parameter gtk-primary-button-warps-slider which should be set to false.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

Thank you, all worked fine.