Index elements lost when document is closed

I have a problem with a document I’m writing. I put a general TOC at beginning of text and it worked perfectly, but, recently, when I save and close the document and then I re-open it, all index items are lost. They are not marked as TOC elements. I tried also with analytical index, but behavior is the same.
Also updating LibreOffice to last version did not fix the issue.
Can someone help me, please?
Thank you

In what file format do you save your file?

Only in ODT file format

Has this been answered?

I have the same problem on a number of documents. All saved as ODF under windows environment. I have marked words to be added to the index, generate the index and it is displayed at the end of the document where i inserted it. Save the document, re-open and generate the index and it will be empty. All the marking of index words has disappeared. Tried in varous document. I am running Version:

I just updated the index after using “reload” from the File menu. It disappeared again. I right clicked the index and selected “Edit”. A message pops up stating: document in use…Document file 'idxexample.odt" is locked for editing by yourself on a different system since… (nothing follows). I then have the choice to open in read only, open or cancel. Strange.
I have tried creating a new index which showed the same behaviour.

The document in use is the one that appears in the left pane, it shouldn’t influence the behavior of Libre, but it’s a nuisance.

Please upload a sample file.

I can’t upload as it says I need 3 points. I created a stripped down version of a much larger document that works well to reproduce the issue.

Okay, I gave you some karma to upload that file.

Wait, you aren’t the OP. So that didn’t help.

OP? Off duty Policeofficer?

Original Poster. :=)

Shall I start a new post?

That’s better.

New post under ID 84308 with header All items marked for index lost after saving ODF document