Insert page field and page count numbers are wrong

The page numbers are wrong in the Insert page field and Page number count field in I there a work around or fix?

There had been a fix for page numbers end of December. Please update your version. The stable version is on 4.2.1. and pre-release on 4.2.2. You can download from and test, whether it solves your problem.

I am using and I am having a similar problem. I have a two page document that uses the Page X of Y format. On page 2, the page count is correct but the page number field is set to 1 and will not update.

I have the same behavior on for Windows. Starting on the third page the numbering is askew, and this document doesn’t use sections. There seems to be no way to simply tell the document to give the page numbers a “factory reset” so that it numbers are in correct order from beginning to end.

Please attach the document or provide it for download. There is likely some mess in page style or in using offset. The error with page number 0 should be solved in the meantime.

Please attach the document or provide it for download.
I was unable to upload the file sample as I’m a new user with no points.
I’m using and have the same problem.
Page 1 of 4 is correct, page 2-4 are incorrectly listed in the head as one page LOWER (pg 2 is listed as pg 1, 3 is 2, and 4 is 3) than they are.
Page error occurs even BEFORE I Save (as soon as I add the additional pages).
NOTE: I confirmed the page errors do not occur if I use carriage (CR) return at the end of the page (every time) - only when I add a CTRL-CR somewhere in the document. Another weird thing is that it does NOT always show up right away - but when I’m typing or moving (normal carriage return) between pages.
Thank you.

Just downloaded 4.2.5 after restoring. I have the same problem! page 1 to 12 ok, then page 1, page 1, page 0, page 1 to 36. I have same page style everywhere. I do not understand anything. Please help!

OK just found out. Someone ask a similar question and the answer is … close the document then open it again… It worked for me, good luck!

Using version, having the (still) exact same problem. Also solved by closing and reopening the document. It’s OK, but the bug still seems to be there…

I’m having the same problem (Writer I’ve just opened up a two-page document, and the footers give a page count of 3, with the first page number given as 0 and the second as 1.

Okay, so after looking into it a bit deeper, it seems that the problem maybe limited to .docx files (at least saving files as .odt or .doc seems to solve the problem).

Version Fresh - same problem.