Inserting Columns in Writer Tables - Preferences are not correct

I want ot have my table in writer that way, that when I add a column, the table size (overall) changes.
This should be done with “Preferences/Writer/Table” → “Variable”. However, It does not matter what I select, whenever I insert a column all columns are changed in size.
Do I do something wrong or is this a bug?

seems to also be posted as tdf#131237

I bet you’re on a Mac :wink:

It looks as if Tools>Options (Preferences under MacOS X), LibreOffice Writer>Table Behaviour of rows/columns has no effect. Anyway, built-in help gives little or no clue to what should happen in which circumstances.

The only way to have custom action on the table seems to use Table>Properties, mainly when Table tab Alignment is set to something else than Automatic. Also when you play with Columns, you should check one of Adapt table width (effective when alignment is not automatic) and Adjust columns proportionally (by default a change of width affects first the column at right).

I don’t know if this is a bug because what the option is supposed to do is not clear for me.

The OptionsWriterTable settings are actually under Keyboard Handling option group. And as such, they manage how Writer’s keyboard shortcuts (e.g., Alt+arrow keys) operate on table row/column sizes.

What you see is not a bug; see @ajlittoz’s answer for the intended way to control what happens when you add columns.