Install Libre Office 6.1.5 and later failing

I tried to upgrade libreoffice from version 6.0 to 6.1.5 and the installation proceeded as expected until about 60%-70% complete then I receieved a message ‘rolling back…’ and then a message saying that the installation couldn’t complete and I should try again. I subsequently tried with higher versions but these exhibited the same behaviour. Something in the installation appears to have wiped the old version of libreoffice 6.0 including the icons etc. I have hundreds of odt files but now cannot access them. Can anyone help? My system is Win 7 home premium x64

Update orig+22hrs
I have tried to install version 6.1 again today ( 4 or 5 times) with a new download from the official download site.
I have observed that the process fails at the second creating folders stage i.e. after copying files and updating registry etc.I have given permission to the installer to 'make changes etc. so I don’t think it’s a permissions issue. The same message occurs “rolling back…” There are no windows errors flagged it is the installer that fails everytime.
Before someone re-posts the ‘see the faq’ I have enabled windows update downloads and I have checked and the update required in the FAQ is already present. My system already has the Windows2015 c++ distributable.
I found an old installer for 6.0 in my archives and have reinstalled this version without any problems. I would still like to use an update to a newer version but at least I can get at the old files now.

I downloaded the msi file again; this time from the archive as per the faq and ran the log file. The final entries in the log file are shown here. Obviously I have the whole log if this helps but I am puzzled why Rootdrive property is set to E:. [Solved MSI looks for the disc with the largest free space.}

update 31/05/19

I’ve tried the install again and have created the logfile which can be found here.

I have had a cursory look but the only glaring error I can see is wusa.exe failing. However this is puzzling as the update service is active and running and the temporary directory that it uses exists and has the correct permissions. Of course this may be a red herring…

Can this help?: General Installation Issues (Windows) - The Document Foundation Wiki

Is there a log file that could give me a hint where the installation is failing?

;-D did you actually read the FAQ carefully?

I’ve seen that the faq gives a command line to create a logfile but haven’t had time to do this yet as I’ve been busy on other things.

I downloaded the msi file again; this time from the installer and ran the log file. The final entries in the log file are appended to my update. Obviously I have the whole log if this helps.

Is it possible that the C partition of your system is out of remaining disk space?

Obviously I have the whole log if this helps

Obviously yes - only that whole log could help, not some final lines :wink: - the FAQ doesn’t mention any cuts of the log file.

to Cookievore : the C drive is only about half full (>240GB free) so I think there’s enough space.
to Mike Kaganski…Will share the zipped log; just plowing through the terms and conditions and privacy clauses of Dropbox. Having been involved with the UK rollout of the EU data directive and having had personal experience of data leaks from Facebook I have some inkling what casual permission to use can cause. Please bear with me.

Have updated question with logfile link

I have finally suceeded in tracing what was wrong. Having created the install logfile I looked in it and the windows update was failing. As I was installing as administrator I presumed that this would allow the installation calls calls to have the same permissions. When I looked at the permissions for the temporary folder that the windows installer uses I discovered that there were full permissions for the user account ( which is why the directory was able to be accessed by another install of octave that I had run since trying to install Libreoffice 6.1.3… evidence fragments still visible which these installs created ) however the permissions for SYSTEM were all blank ( not even id’s or tickboxes shown in the gui… peculiar?) I used advance mode to reset these and everthing was hunky-dory.

I then tried the re-install ( from cmd: again with logging) and this time it succeeded!!

Thank’s to everyone who tried to help, especially Mike Kaganski for his patience with a noob.
I can only add a tongue in cheek observation made by Sir Terry Pratchett in an interview I once saw about the godlike powers of software giants: “Many are the wonders of Microsoft”

Thanks again; I’ll get back to my writing now.