Install the hyphenation package for locale "ka"

How can I install a hyphenation package?

OS: MacOS Catalina

LO version: 6.4.7.2 (plan to upgrade to 7 soon!)

My present locale is Greece and I would like to install hyphenation packages for Greek (I think that for English and French (?) they are already installed. The “ka” locale appeared in the error message as I opened LO today. It really means nothing to me.

Please edit your question to add OS name, LO version and your present locale.

Do you mean the “Kâ” language spoken in an area comprising the Central African Republic or the Georgian language (ka in ISO-639-1)?

Note that here answers are reserved for solutions, please take care to use the edit link. Also paragraphs are separated by double Enter, not single Enter (HTML convention).

You probably changed the document language in some way unintentionally. Ignore the error.

I am not familiar with MacOS packaging, I can’t help much. Under Linux, there are hyphenators (Hunspell) and language packs for Greek (hunspell-el & libreoffice-langpack-el), English (hunspell-en-GB, hunspell-en-US & libreoffice-langpack-en) and French (hunspell-fr and libreoffice-langpack-fr).

You can tell if any is installed in Tools>Options (may be in the Preferences menu in MacOS X), Language Settings>Writing Aids.

The “ka” locale appeared in the error message

And what was the message?

The message was:
Install the hyphenation package for locale “ka”

Is that the exact wording? Weird then. The matter is that hyphenation packages are for languages, not for locales. Just curious: if you install a dictionary for Georgian, does it eliminate the message? However, the extension does not contain a hyphenation module, which means that it may not simply exist.

Instead of (or prior to) installing a dictionary for Georgian, I closed LO and opened it again.

I opened the same file to edit and the message now became: «Install the hyphenation package for locale “la”»! N.B. an “l” in the place of the “k”.

So it appears that the message is not relevant to an actual lack of a specific dictionary… (in any case my texts are not related to Georgian or CAR.

I checked the “Writing Aids” as suggested by ajlittoz and found that hyphenation and other dictionaries seem to be already installed for the Greek language. So, most probably, everything will work OK.

la = Latin

Close LO and open it again. Is now the message for “ma”? In which some internal counter has gone crazy.

This time there was no error message at all. Strange, isn’t it?

This morning the message appeared again, the two letters defining the missing hyphenation package were “tr” (Turkish?). I think I must live with these messages, deleting them when they appear. It is only once every first time I open the document. I think we already spent too much energy on a (TMHO) minor issue. Thank you all for your interest and effort.

Something is wrong with your configuration. Tell us if this still happens when you upgrade to 7. Maybe you consider upgrading your OS. This may also be a factor. Good luck!

For starters, try to reset your use profile.

hyphenation packages are for languages, not for locales

Sometimes, sometimes not. For example, there are en-US English US and en-GB English Great Britain dictionaries and hyphenation.

The message should output the full locale / language tag though, not just the language code. Which is fixed for at least 7.2

Try Orthos: Download Orthos from SourceForge.net

Thank you. I will try this as an improvement.

This seems very popular issue, also for me at latest ver.7.1.4.2. I have same kind of warning.

The root cause may be the following:

I copy some text from MS. word, apparently it was in other locale, while my LO has locale of en-UK/en-US. If you mark those text, at LO’s bottom status bar, the locale will be display its origin(e.g. ka: Gerogian.)

while the system language set to EN and Writing Aids/[options] Hypernate in Preference/Language Settings was ticked, those copied text is then missing “writing aid”/hyphenation guideline, thus comes the warning.

The solution is:

  • install the missing language (e.g. Georgian) for User-defined Dictionaries. This can be easily done (in fact the same procedure as MS office.) by double click the status bar on the language section, where e.g. Georgian indicated. From the pop-up menu, you can see only english listed and is asking more … to install, then you can add the language, e.g. Georgian (as dictionary) . Thus LO knows how to interpret(hyphenate) the language of e.g. Georgian.

Reopen the document, warning will be gone.


To double check, go to Preference/Language Settings/Writing Aids/User-defined Dictionaries, KA/Georgian should be listed as installed.

Further more, I would recommend install all your most used languages into User-defined Dictionaries, e.g. DE/FR/ES… in case you have mixed/multiple languages in editing. (This is the same as MS office for auto correction/language).

Some people maybe prefer “quick & dirty” solution t switch off the [options] Hyphenate special regions. But I would not recommend, because you don’t know what language/dictionary included in your base installation (same as MSOFFICE) package, e.g. in EU there are so many languages maybe not installed as default.

At the end, it would be recommended for that warning line to give a link to describe more info for user to understand.