Installation quits with error 1909: Cannot create link to LibreOffice

After more than 10 years using LibreOffice (for 3 years with Windows 10) it started not able to save any data. De and Reinstall didn’t work and during typical installation, copying data, nearly finishing the install quits with the above error plus adding that maybe the target doesn’t even exist or that I have no authority. How can the install not be able to link to the file it almost completely finished installing? Beat me…

I downloaded an other version and had exactly the same result. Can any one please help? I’m the only user on this PC and thus have authority to install anything. Never had such problem before.

Please have a look at the FAQ of @mikekaganski.

Do you download from here?

Thanks, I added LibreOffice to the exception list. Saving with LibreOffice to the hard drive now also works.

Install error 1909 on Windows 10 (Unable to create shortcut to LibreOffice and/or no authority to target folder…Installation failure) is PARTIALLY solved after finding here the solution. Namely - guess what - WINDOWS DEFENDER!!!. It turns out that Windows Defender has been known to prevent installation of what it might consider to be “intruder” such as in my case LibreOffice. LibreOffice has been installed successfully and works okay except it still will not save to any folder on the hard drive. No problem saving on a USB chip from which I can copy the saved file to the hard drive. The error message I get upon attemping to save is a general write error. So I can use LibreOffice and write to a USB chip from which I can copy back to the hard drive. This is a pain but hopefully there will be a solution to this problem as well. I tried to disable Windows Defender before saving but that didn’t help.
Thanks to I can again use LibreOffice.


Did you read the FAQ carefully? :wink: The bit about “in Windows Defender case, it might be necessary to add LibreOffice’s soffice.bin to the Defender’s Controlled Folder Access exceptions list” - which is not the same as “disable Windows Defender before saving”.

Thanks Mike, I removed LibreOffice and soffice.exe from the dagerous Apps list. No problem saving.

Correction: not removed but added soffice.bin to the list of apps that have access to the controlled folders.

Not so much of a solution but a further question on this 1909 & 2902 errors on installation of the msi for ver.
Running latest Win10 x64 19h1 updates (as of 20 Oct 2019).

During the installation of I get the two errors irrespective of where the downloaded file is.

Partial solution was to totally disable Windows Defender and the install runs through no problem.

But still unable to Pin the Desktop shortcut (or the soffice.exe file itself) onto the Task Bar, even though soffice.exe has been added to the exclusion list. And this prior to re-enabling Defender.

Also the link on the FAQ to “it might be necessary to add LibreOffice’s soffice.bin to the Defender’s Controlled Folder Access exceptions list” gives a 404 Page not Found error when the link is followed to the Microsoft page. So no help from that end.

At least LibreOffice IS installed; quite how workable it becomes when saving files to my User directory (or to my personal D:drive) has yet to be investigated.

Strange in some ways because I had an earlier version of L/Off installed without issues a few months back (July 2019), so was surprised at the problems with this version - whether it be MS & Defender of something in the L/Off msi.