Installation Stuck on Creating Shortcuts

I am trying to install / upgrade LibreOffice on Windows 8.1 and the msi installer appears to be getting stuck at ‘Creating Shortcuts’.

I am running Bitdefender 2014 build if it helps and have also tried re-installing LibreOffice 4.1.3 which was working correctly until I tried to upgrade, but this now stalls at the same point.

Has anyone had the same issue / have any ideas how to troubleshoot ?

Thanks in advance.

After another evening of testing, I have managed to resolve this issue.

Once the installer gets stuck at ‘Creating Shortcuts’, the only solution is to reboot or end task the installer process. Once this has been done, try running the 4.2 help installer. This will offer to rollback changes made by the stalled main installer.

Once uninstalled, remove all LibreOffice folders (if there are any) including anything left in the start menu. Open a cmd window and type %temp%. Clear this directory.

Try to reinstall LibreOffice again and the installer went through. It is also possible to get the install to write out a log file to see if it gives anything away, although for me this was not required.

The command to do this is :
msiexec /i LibreOffice_4.2.0_Win_x86.msi /Lv LogFile.txt

This should be run from the drectory containing the installer and will create the log file in the same folder.

Hope this helps someone else.

I had this problem also, but the issue was not resolved with the answer. But, it was resolved after I uninstalled Bitdefender. This problem did not only occur with installing LibreOffice, but also other applications like Classic Shell for instance.
Bitdefender didn’t give a message that it was blocking something, so that’s really weird. I installed another virusscan suite I didn’t have problems with. And asked Bitdefender for a refund.

When I saw your response I realized Bitdefender was the problem for me too. If you don’t want to uninstall Bitdefender completely, temporarily disabling Active Virus Control also works.