installed custom font - now it taken over all menues

I am usig MXLinux 19.2. with Libre Writer. I can’t remember how I installed it. I expected it to be added to my lits of font choices within LibreWriter, but now as I say its taken over and I can’t get rid of it. Where is the config file that would allow me to do that. I deleted the font, but its still there like an unwanted guest.
I would send you images of how its taken over if I knew how to do that

The font is a Frank Lloyd Wright font called p22_EAGLEFEATHER.
I have found a bunch of config files, but nothing that has the font mentioned above in it.
I unintalled LibreWriter suite but it didn’t make any differnece.
Any help would be appreciated.
Edit of question with addition screenshots.:

I expected to be able to add that font to my collection of fonts so that I could use it if I chose. I did not expect to have it change the basic program font as it seems to have done it a strange way.

Edit your question to explain its relation with LibreOffice. Mention your OS (and LO version). How did you install the font? What did you expect? (to replace the system font, to add to the collection of available font? …) How did you delete the font (manually or with a utility)?

What does “now it taken over all menues” mean?

Answers are reserved for solutions, so modify your question with the edit link to provide the needed information.

From your screenshot, the font is still present somewhere in the system. Please, copy the version information from Help>About LibreOffice. In particular, I’m interested in what is reported by VCL:. This will tell which kind of widget manager is used on your PC. What is your desktop manager? Probably GNOME or MATE.

You have probably damaged a deeply buried configuration file (for GTK+?) during your attempts. What may be possible is the file has effectively be removed but the name is still there somewhere and the OS uses a replacement for the absent font. The screenshot doesn’t look like the sample for Eaglefeather on the Adobe site: H has a double horizontal stroke, E has a trapezoidal shape, the horizontal stroke in A is broken, … No such artefacts in the screenshot.

Thank you for your interest. I have screen shots of the information you requested. but I don’t have that option here.
Both those screen shots are using the rogue font.
The LibreOffice Writer version is 6.15.2 and the VCL: GTK3.
The desktop manager is: “Xfce 4.14 on top of Debian state”.

You can add these screenshots by editing your question. I suspect some GTK3 configuration collateral damage. Unfortunately, I’m not versed enough in GTK+ to point you in the right direction (I prefer the Qt widgets).

Well, well, The font is still lingering around. You should try to remember how you installed it to use the same utility top remove it safely and reliably.

In an old computer with Xfce, I found the Parameter Editor (don’t know if this is the English name because I could find how to change system language) in the Application Menu, Parameters sub-ùenu. In category “xsettings”, under the Gtk hierarchy, there is a “FontName” parameter. Mine is set to “Sans 10” which sounds sensible. Yours may set to some funny value. Try resetting it to a more traditional font.