Installed Libre Office - split databases now not working

One database was split from scratch worked before upgrade - now can’t get table.
Message says “the connection to the data source '2017 Members Split Database” could not be established. The driver class 'org.hsqldb.jdbc driver could not be loaded. The additional driver class path is file ///C:/users/empadmin/Dropbox/driver/hsqldb.jar. I placed a hsqldb.jar file at that location but no success.
The other database was created from an embedded database and worked before the upgrade.
The message when I tried to access the database was Please add a copy of the HSQLDB engine (hsqldb.jar to the current folder C:/user/empadmin/Dropbox. I added a copy at that location - no success.
Now whenever I bring up LibreOffice class paths are inserted when I cleared them out.
Note: an embedded database was not affected by the upgrade and still is functional.

It appears that the split database that was started from scratch is now working, but I don’t know what was done to get it working. The line at the bottom of the screen for this database has “JDBC: hsqldb:file:///C:…” which, I believe, indicates that it is a split database.
I am still not able to get the database that was split from an embedded database to Work. I believe that this problem may be caused by my not being able to clear the 3 class paths so that HSQLDB can find my data.

Can’t see how just an update to LO would affect the split DB. Been running split DB’s since LO v4.3.x and currently at V5.2.3.3 and never had a problem when upgrading. Embedded DB’s wouldn’t be affected since the location is within LO.

With a split DB it depends upon the method the split was performed and what if anything was done afterward. There have been two (somewhat automated) methods of splitting DB. The first had no HSQL update (used v1.8 I believe) and the latter uses HSQL v2.x and also provides some portability if the macros aren’t touched.

I can easily reproduce your problem (except for the inserted class paths - baffling) by moving an older type split DB to a new location. Only have to change two things to fix this. Using a BACKUP COPY (always protect yourself), open the .odb with an archive manager. Right click content.xml file and open with a text editor. Look for:

data-source-setting-value>file:THE DIRECTORY CURRENTLY POINTED TO/hsqldb.jar

and change it to the correct location of the driver directory of the .jar file. Save the change and update the file in the archive. Second, run the .odb and from the menu select Edit->Database->Properties... and make sure the directories in the Datasource URL are correct. Those two steps should fix the problem.

With a newer split DB there should not be a problem moving the DB around (I have not experienced any). However if things were somehow changed, look at the same items previously mentioned.

Edit 12/12/2016: At this point it may be best just to move this all over to another (probably newer) split DB. Follow these instructions:

  • Create new directory.
  • Place copy of database sub-folder from existing split DB into this new directory
  • Create sub-folder named driver in this new directory
  • From this post get hsqldb.jar v2.3.2 and sqltool.jar (both about halfway down article in the text) and place in the new driver subfolder
  • Also place a copy of that hsqldb.jar v2.3.2 file in the main part of the folder for initial start-up (don’t need afterwards)
  • From same post, get split wizard .odb and place in main folder
  • Run wizard and table(s) should be available
  • Finally, with new DB open, run old split .odb - forms, queries, reports and macros can be copied and pasted into new DB.

This should alleviate headaches of moving the folder around. It automatically resets location when moved. However, if you’re still looking at using Dropbox, make a copy of the entire folder first for safety.

I opened content.xml and changed data-source-setting-value>file to the directory where hsqldb.jar was located along with my .odb file. This time I received Error1: An exception occurred Typ:
runtime exception Couldn’t open library element stream. (line 17). BTW I had also edited the Database Properties so that the directories in the Database URL agreed with the line at the bottom of the screen.

Based upon your comments, something was changed that should not have been. Error at line 17 means nothing since each content.xml is based upon the database created. Changing the line specified should have nothing to do with the error received. An incorrect change in the line specified would give an error such as “hsqldb.jar could not be found”.

I have got it working sortof. After making changes to a new content.xml file and running the .odb I get the message"Please add a copy of hsqldb.jar to the current folder C:/user/empadmin\Dropbox\Split Trail Maintenance"
I select Retry and get the same message. Selecting Abort, the message disappears and everything seems to work properly. BTW hsqldb.jar does reside in the Split Trail maintenance subdirectory. I’m getting close. Thanks for all the help.

I’m just glad you got it to work (sort of). Obviously you did have a backup before you started - had me a bit concerned.

One possible fix. You mentioned ‘extra class paths’. This information is kept in the user profile and it may be corrupt. You can try resetting the user profile - instructions on this page.

I forgot to mention that I was able to clear Class Paths. I was clearing the paths and they were removed from the screen, but I did not see the “Save” button which was off screen. After a number of tries I scrolled down and saw the “Save” button.
Instead of selecting Abort in the problem above I selected Ignore. This made the database unusable so I reinstalled everything again in Dropbox…

This time I got the following error: SETUP: macro code error
Error 1: An exception occurred TYPE: Exception
MESSAGE: Couldn’t open library element stream (Line 17)
I was given a single buttion (OK) to select. After pressing the button the program worked.
BTW The line at the bottom of the screen shows that the mydb files are located outside Dropbox

  1. Will the program continue to work ok if I don’t fix the problem?
  2. does the error give a clue to the fix?

I’ve got a couple of questions. Is this split DB using HSQL 1.8 or the newer process which includes HSQL 2.3.x? Do you still have the original embedded .odb and have you done much additional work to it since converting? BTW - this is the second Base problem in last few days where Dropbox is involved. ???

How do I tell. Ran HSQLDB.jar and selected HELP then About. . Did not tell me what version. Revision date on file is Nov 26, 2013. This database was created from scratch about that date in 2013, and I have the original which is not in Dropbox. The original still runs ok. I moved the front end and back end files to dropbox. When I run the file (Trail maintnenance.odb), I have the problem described above. I edited content.xml to point to Dropbox directory with mydb files - did not help

Forget the version. See Edit in answer. This will move you to HSQL 2.3.x and give better all around capabilities. Hopefully it will relieve you of ALL the problems.

Can I create the new folder and do the Edit procedure entirely in Dropbox?

You can try, but at this point I don’t know enough about Dropbox to say if it is causing problems.

I’m down to the step "get split wizard.odb and place in main folder. All I see in the post I’m directed to is Split_HSQLDB_2.3.2_wizard_v3d.odb which says already includes HSQLDB2.3.2. Is that what I download?
I have already loaded that in the driver subfolder in step 4. Going down to the converting from imbedded to split option I see I can download mydb_wizard.odb which apparently does not include HSQLDB. Do I download that instead?

Download “Split_HSQLDB_2.3.2_wizard_v3d.odb”.

I have them working again now that Christmas is over. However they are not portable. Using Libre Office Portable, when I try to run LibreOffice portable I get "The connection to the data source Split_HSQLDB_2.3.2_Wizard could not be established. The driver class ‘org.hsqldb.jdbcDriver-v3d’ could not be loaded. The additional driver class path is 'file///F:/Portable Apps/Libre Office Portable/Split%20Member%20 Database1/driver/hsqldb.jar. What does "%20 mean on either side of member?

The %20 denotes a space in a URL definition (personally I stay away from spaces/special characters in all naming). Sorry I cannot help with LO portable versions. I don’t use Windows anymore. However, this post may be of help - click here.