Installed ttf fonts not showing

I am on Pop os
I installed LO 7 and then installed some popular Persian fonts, the fonts are shown in font manager and Editor but dont have access to them in LO font list

Have you restarted LO since installing the fonts?

Edit your question to describe the font characteristics. Type 1 fonts are no longer supported by LO rendering engine. It is sometimes difficult to tell if a font is type 1 because file extensions are not always used consistently.

In principle, you’re safe if the file has extension .otf or to a lesser extent .ttf (there are several format variants).

Yes of course, I restarted LO and system but not solved
All fonts are truetype as shown in the font manager

Can you give a link to one of the problematic fonts so that I can experiment on my Linux system?

I’ve tested FreeFarsi (from SourceForge) and it works for me, even without rebooting. My system is Fedora 32 with KDE desktop, LO Pop OS is Ubuntu-based and may exhibit some particular behaviour.

I forced the FreeFarsi font with Format>Character. Not sure if the font menu in the toolbar can pick up a “strange” font before it has been used at least once.

I used the “configuration settings” (KDE utility, not the same for Unity, MATE or GNOME desktop) utility to install the font as a user-only font. If you manually installed the font, it may have ended in an unusual location and is thus invisible to applications.

Just installed fonts through font manager and solved, thanks

Fonts are managed by the OS. Manually installed fonts may not be stored in folders searched by the OS when looking up fonts.

To avoid problems, always use the tools provided by the OS. The fonts will then be installed in “official” folders.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.