Installer stuck on "Registering fonts"

I’m installing LibreOffice 64x on Windows 10 Pro Version 1909 (OS build 18363.815). Everything runs fine until the “registering fonts” status, where it’s been stuck for dozens of minutes. I’ve tried re-running the installation but it gets stuck at the same stage.

I installed and then uninstalled the older version, then retried to install the latest version and it worked.

No. Mine on July 13 '21 with windows 10 64bit operating system, LibreOffice 7.1.4 x64 it’s stuck on ‘Registering Font’ I tried to stop it using the ‘cancel’ button but it’s not worked, then I tried with the ‘Task Manager’. The worst thing is it’s messing up the whole ‘window installer’ process, like when I’m trying to install other software it will be stopped by showing the error 1704 installation suspended and it’s forced to choose ‘undo the previous installation’ or ‘not’ , but when I choose the ‘undo’ it is came back to stuck on ‘Registering Font’ again, probably it’s happened because the previous installation is not finished yet, stucked in that problem.

Please if you have any solution. Thank you.