Installing the LanguageTool extension.

On Windows 7 operating system, maximum 64 bit SP1, when installing the LanguageTool 5.0.1 extension for LibreOffice (x64), an error message is displayed about the existence of an extension file at the specified path shown in the attached screenshot. Java 1.8.0_261 is installed in the latest version, both for 64 bit and 32 bit. Other extensions downloaded from the libreoffice site were installed without problems. The old LanguageTool 4.8 extension that worked with an older version of LibreOffice installed fine. Now it is not installed either, the same error message appears. How to overcome this problem?

image description

A hint: on you may ask Yakov (from LT team) about that.

Not sure what the non-English error message says. If you post the message as text rather than an image, then it could easily be translated. But with any error that mentions the uno_packages cache, the first question is always whether you have tried resetting your LibreOffice user profile to see if that fixes the problem.

This is:


    Add Extension(s):
    <path\to\LanguageTool-6.4.oxt> does not exist.
            [ OK ]

Note the version of the oxt that is being looked up.

Yes, you are right about this message. I reset the user profile and LanguageTool 5.0.1 is installed on LibreOffice 7.0.3.
Thanks for the help.

(Repeating information from the comments so that this question can be properly closed out.)

Whenever you see an error message about the uno_packages cache, reset your LibreOffice user profile and see if that fixes the problem.

Adding and removing UNO packages can often cause the cache to become corrupt, at which point it becomes necessary to remove the profile and then restart LibreOffice to create a new one.

Thank you very much for your help. I have already figured out the problem on August 7.

This is not an answer please use the comments.