Installing version 6.2.3 I repeatedly get a installation interrupted error message?

Operating system windows 7 pro
Browser Opera
0nly other programs installed
MS Office

Supposedly tdf#124794

disable windows update service or please wait to version 6.2.4

not “disable” but “stop before installation, but not disable”

@mike-kaganski from what I see in the the log, stopping will not help. LibreOffice does the stopping on its own: InstallMSU: Service status is SERVICE_RUNNING
InstallMSU: Successfully sent SERVICE_CONTROL_STOP code to Windows Update service

From what you see in the log, you didn’t understand my reply. Because I think that I had implemented the stopping wrong: I didn’t wait for it to finish, thus likely wusa.exe was started an instant later, while the WU service was still in “Stopping” state, not in “Stopped”; and my suspicion was that this is what disallows wusa.exe to continue (properly starting the service itself, and proceed). I made a blind fix in tdf#124794, but I need confirmations if manual stop (= some pause before installation starts, making sure WU service is in completely stopped state) helps.

I see. Then nope, it doesn’t work. I started looking for that problem because I had error 1603 when installing LO 6.2.3 on Win7. I found out problem is that LO install tried to install windows update via wusa, but that update is not applicable to my system (I intercepted the file LO setup tried to install – TMP530F.tmp, tried to install it manually via WUSA and got the message that it’s not appropriate). And some other place I found out that 6.1.3 also had some other problem and will not try to install the update if update service is disabled. Here’s log: LibreOffice_6.2.3_Win_x64.msi.log on Windows 7 64-bit -

@LogicDaemon: why isn’t it applicable? do you have Windows 7 SP1?

Anyway, what you report is different here, where the problem is not inapplicability of the patch…

or maybe not. :frowning: sigh

Again: your log shows that WU service was running at the moment installation attempted to install the update. My idea was to try installation with WU service stopped.

it’s hard to know why, Windows doesn’t say anything specific. All I know is that it says update in not applicable: (screenshot is in Russian, sorry). Yes, it’s SP1, with all critical updates and some recommended ones (auto-update is on, but recommended updates are not installed automatically – I check them and approve manually before installing to avoid another WGX banner spam).

WU service was running at the moment installation attempted to install the update

it’s log from the first try, I didn’t try again before some googling and trying to install the update manually.

I’ll try again, wusa can run with log too… What’s the update name inside the MSI file? I’d like to avoid uninstalling and then reinstalling LO…

I didn’t try again before some googling and trying to install the update manually

I got an idea that you tried, having read “Then nope, it doesn’t work”. Could you please clarify?

By the way, the “update is not applicable” is not an error in our installer; I specifically treat that result.

screenshot is in Russian, sorry

No problem, I’m Russian.

maybe I’m mistaken, uninstalling LO now, it takes it’s sweet time…

What’s the update name inside the MSI file?


here is update install log: TMP82DA.tmp install log.evtx - (converted from evtx which wusa writes)

there were 1 more comment I added before adding the update install log, but I don’t see it now… Here it is again:

well yes, stopping wuauserv before running install helps, without disabling the service! I’ve mistaken.
Full log with the service stopped here: LibreOffice_6.2.3_Win_x64.msi.log on Windows 7 64-bit -
Still, the update itself fails (there is comment above)

the msu I download from Download Update for Windows 7 for x64-based Systems (KB2999226) from Official Microsoft Download Center differs from the tmp file which LibreOffice tries to install… has newer file. Maybe that’s why older one is not applicable?

yup, seems so Imgur: The magic of the Internet

Fine; it tells

InstallMSU: wusa.exe succeeded with exit code 0x80240017

… which is, per , “WU_E_NOT_APPLICABLE” - which we treat as success. So thanks for testing the stopping service workaround.

As for the updated MSU: we take the MSU pack from Download Windows 10 Universal C Runtime from Official Microsoft Download Center ; and I don’t see an updated version. But anyway, until we find one (a single pack containing the MSUs for all supported platforms), having that older one, and having “not applicable” for systems with a newer version installed, is fine.

Seeing that your installation succeeds, I’m glad you have it working. Thank you again for your help!