'Invalid Sheet Reference' when attempting to create advanced filter

I keep getting the above error. In order to demonstrate, I created a basic sheet and tried to filter on it:

I’ve < 3 points so the screenshot I have will have to wait. Once I dismiss the above dialog, I also get a “This range does not contain a valid query” The folowing is my sheet:

    Key	Student_id
    IVPW	502694
    IVPW	502011
    IVPW	502010
    IVPW	502695
    IVPW	503335
    IVPW	502697
    IVPW	503336
    IVPW	503714
    \ Sheet2 /

For the filter cell, I’ve tried basic formatting etc.

Student IDs column range is C5:C12. Filter cell is C3.

Go to Data->More Filters → Advanced Filter
Click on filter cell C3.
This populates the “Read Filter Criteria From” field with: $Sheet2.$C$3

Click “OK”

Above errors are thrown.

Trying very basic filter values is not working either (i.e. =‘502694’, >0 etc.)

The sheet above was pasted in from data in an adjacent sheet. The origin was an Excel document, converted to ODF.

Thank you for your time reviewing this.

The dialog title is "LiberOffice 5.1
About Version info:

Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8); Calc: group

Hello @eggmatters, i upvoted your question so that you can upload your screenshot.

Thank you! Will do presently.

Hello @eggmatters,

Advanced Filter expects a range that contains the filter criteria (including the field name), in your example that would be $Sheet2.$C$2:$C$3.
Hope this helps, lib

Hey! That made the error go away. I’m not seeing the filter actually filter anything though. Shouldn’t it be only showing me rows that match the filter criteria?

Looks the data range selection includes the filter. Please select firts the data range and try the filter as commented by @librebel.