Invisible formula field and other settings (black font on black background)

Hello everybody,

I’m having an issue with Calc in which some of the fields aren’t visible due to the black font on black background (such as the formula field or other settings).
A couple of screenshots are as follows:

I’m not using any Themes, I’m using the default look for Calc.
The colour scheme should follow the System Theme (default theme, not dark).

Here’s some additional information about my version of Libreoffice Calc:
Version: (X86_64) / LibreOffice Community
Build ID: 420(Build:3)
CPU threads: 8; OS: Linux 6.6; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Does anyone have any idea why this issue has happened?
Thank you!

problem probably from install history …

what flavor of linux is this ?
what if you switch to another theme ?
what if you try with another user (e.g. newly created) ?

I’m using Solus Budgie.
I’ve tried to change the Themes via Calc but it had no effect. I’ve also tried to change all the black colours available in the setting page of the screenshot provided but still no effect. I might give a try by changing the System theme.

I’ll keep you posted on the results, thanks