Is a conversion process needed to open impress slides created in 6.4.7 with 7.1.3?

I can open impress slides created in with or with Office PPT. They look fine in either app. When I open the same file in the graphics are highly corrupted. Circles have random flat spots and light corruption to the line itself. I have a series of black filled round dots about 1/8" in size. They now have what looks like two cat’s ears sticking out of all of them. Mostly up but some to the side. I have drawn neat coils and they now look like hand drawn while travelling fast on a rugged mountain road in a Jeep.

I am trying to see if an upgrade of Libreoffice from 6 to 7 will help cure the random screen lockup problem many people get with linux versions. Incompatibility with version 6 drawings however makes 7 a show stopper for me.

Any ideas on how to get documents migrated or is there a fix in a later 7 version? I am going to go back to 7.0 and see if it works any better.


In LibreOffice 7.1.3:

If set, try to disable Skia in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use Skia for all rendering and check whether that fixes/mitigates your problem.

Another **Test** (this is **not** a solution) whether LibreOffice user profile is causing the issue:
  • Start LibreOffice
  • Restart in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Click button Continue in Safe Mode
  • Open a file (using File -> Open) and test whether the problem is gone
  • Provide feedback using add a comment about the test result.

Btw: No conversion process required

No Skia option in but it has a Use Anti-aliasing option that I turned on and it corrected the corruption. Unbelievable difference in rendering. Originally, hardware acceleration and anti-aliasing were both off.

Safe Mode: came with hardware and anti-aliasing on and worked ok. I turned off anti-aliasing and the diagrams were again corrupt. It appears safe mode has no affect on the render quality but anti-aliasing does.

No Skia option in

Sure - you seem to be on Linux and I’d overseen this info