Is it possible to set the background colour of a column in Writer?


I’m working on a new CV layout, one with a narrow column on the left and a wider column on the right for the main content. This is one of the standard column layouts under the Format/Columns menu.

What I’d like to do is set the background colour of the left hand column so that it stands out from the main column.

It can be done by selecting the text, right clicking on the selected text and choosing the “Paragraph …” menu item, then Area, Colour and selecting a background colour. However, this leads to bullet-pointed text being partly the selected colour and partly white, like this:


Ideally, I’d like the whole column to be blue. I can’t set the page colour as this affects the main column.

Any ideas how to approach this? I’m open to the use of text boxes or frames but my experiments so far have not been successful.


(inline display enabled by ajlittoz)

You didn’t describe what’s in the other column.

Is your text really column-flow type? I.e. should it be read narrow column first, then wide column (newspaper reading)? I doubt it because you’d have equal columns.

If information in the left column is not directed related to information in right column (where paragraph boundaries should be aligned across columns), your text should not go into multi-column pages. Instead, use a table. In a table, you can set background colour separately for columns (or rows or even cells).

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

I may have a solution to this. ajlittoz is correct. The left text is not related to the right hand text and the columns don’t flow one-into-the-next.

What I’ve done is to format the page using

Format/Columns then choosing the “2 columns with different size (left < right)” option for column layout. (This is the fourth option in the preconfigured styles.)

In each column, Insert a Text Box and resize it to fill the entire column.

Right click on the Text Box and select Area …/Colour and choose the colour to fill the text box. This action will overwrite any text. But all is not lost.

Right click the Text Box again and this time select Arrange > / To Background and this will bring the text above the colour area.

It may be that some of the text ‘leaks’ outside of the Text Box. In this case, resize the Text Box sufficiently to ensure all the text is inside the box.

Admittedly, this seems a bit of a hack, so I’m open to other suggestions.


Whenever possible avoid using text boxes or other drawing objects. Anchoring them is not that easy and making them follow text flow or resize automatically to text size is next to impossible.

The simplest solution is a 1-row 2-column table (if text in each column is really independent). Adjust column width like you would have done for the 2-column page solution. Configure the table for some padding space (this works even if there are no borders around cells/table) to mimic the gutter between page columns. Then set the background for the columns (it will paint the whole column, including padding space within the column; thus your bullet paragraph will not suffer the problem you mention).

Table height will automatically expand to hold the taller column. If you allow the table/row to split across pages, your table can then straddle page boundaries if needed.