Is the bug report interface working correctly?

I was trying to report a LO – MS Word interoperability(1) problem on the main site but the bug report interface was giving me this error:

Saying that the version I choose in the dropdown menu is not correct.
What am I doing wrong?

(1) Really it is reported since 2004 in, but I was suspecting no one has seen it, and trying to report it again through the LO main site to see if someone can notice it…

I know the Bug Submission Assistant (BSA) has been worked on recently. I would say it has not been updated yet to reflect the recent v4.2.0.4 release. It probably should state “ release”.

EDIT: It has now been updated and should work as expected. The entry now reads “ release”. @Rmano, thank you for bringing this to our attention.

I tried even with an older one, but got stuck saying "the page is still loading — please retry after a couple of seconds"or something like that. During half an hour ;-). So well, I resorted to the direct bugzilla interface, which is a bit of a pain… (tried to upvote, but I can’t).

Yeah, I had a similar experience a few days ago and end up doing the same. There is a large change to the bug tracking system being done in February (as I understand it) to create a separate LO bugtracker (rather than use the FDO one) and work on this initiative may be interfering.