Is there a way to change Hebrew numbering to count י...יא...יב instead of י...כ...ל etc.?

In automatic counting functions, LibreOffice offers only one type of Hebrew sequential counting, …י…כ…ל; the standard convention uses י as a decimal for 10, כ for 20 etc. This can make page numbers and footnote numbering akward.

This issue is bug 66212. Please give it some love.

Luckily, though, there’s a workaround:

  1. Use “Default numerals”:
    1. In the menus, select Format | Bullets and Numbering
    2. In the Options pane, select the relevant numbering level
    3. In the Numbering | Number drop-down list, select “Default nuemrals”
  2. Set your locale to Hebrew:
    1. In the menus, select Tools | Options
    2. In the tree view, choose Language Settings | Languages
    3. Change the Locale Setting to “Hebrew”.

that works for me (and several others).