Is there a way to enable javascript in libre office on linux mint 19.3?

I have a writer document that has a box I presume to be a video, that shows “error enable javascript in browser”. So I can’t click on it without writer crashing. I’m reasonably new to linux and for that matter libre office so any help needs to include step by step instructions please. Thanks much for the help.

that has a box I presume to be a video

Funny - you request a step by step instruction for how to deal with what is a presumption

  • for most people editing documents they will not need to load javascript.
  • javascript is mostly employed as a web / browser technology. Ask yourself, does the document you are viewing need access to the internet at all? ; bearing in mind that javascript is a targeted malware/spyware/viral vector.
  • who sent this document, what is its purpose? can you ignore this frame/box?

It may be that it wants to play the video in a browser window. Firefox or other browser might not want to enable Javascript. You might need to look at the options for your browser.

I’m pretty sure Java was installed when I installed LO but it is a long time ago now. Make sure you have Java installed first. Open Software Manager and search for Default-jre. Install it if not already installed, make a note of the path where it is installed

Open LibreOffice Writer. Click Tools | Options In the window that opens go to LibreOffice | Advanced if the table has an entry something like “Oracle Corporation 11.0.7” or possibly even “OpenJDK” and the radio button is filled then you have Java enabled so the problem lies with displaying the OLE object.

If no Java shown, tick the box labelled “Use a Java runtime environment” and click Add button, navigate to where installed. For further info try https://linux4one.com/how-to-install-java-on-linux-mint-19/

I hope this helps, Al

Java and JavaScript are very different things :wink:

Whoops. I didn’t think. Not really LibreOffice then.