Is there a way to force Writer to make every page a certain number of lines?

To be a bit clearer, I understand that the number of lines per page is dependent on the font, size, spacing and margins of the document, but I was wondering if there was a way for each page to have an identical number of lines-25 in my case. It’s nothing imperative so if it’s not possible then that is that, but it doesn’t hurt to ask, eh?

Thank you for your reply(ies) in advance!


EDIT: Something I forgot to mention is that writer uses inches to dictate the spacing rather than points(a point is equal to 1/72 of an inch. Using this to convert my desired number of points to inches usually leads to an irrational number and further rounding by the program). Is there a way to use a different measurement unit?

Tools/Options/LibreOffice Writer/General/Settings Measurement units can be set to points.

Looking for a solution, seems to be an option there, adjusting in the Page style the Text Grid tab. Maybe it is there to solve your question
Decreasing the Max. base text size let to increase Lines per page.
To avoid print the grid change the Grid display option.

This is actually pretty nice. I will look into it and get back to you when I’ve tried it on my project.

I would have liked to possibly upvote w_whalley for the closest answer to my question although all of the answers presented were helpful, but he/she seems to have added a comment rather than an answer so I’ll put it here down below.

I was able to change the unit of measurement the way that was suggested above: Tools>Options>LibreOffice Writer>General>Settings Measurement units and it gave me a bit more control(although ultimately what I was asking for was impossible). I shan’t be picky, however, and the overall result was pleasing.

Hi @Eternal,

I don’t know of any setting in LibreOffice to enforce a limit on the total number of lines per page, but you could file an enhancement bug and ask for such a feature to be added.

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.


@Eternal - Possible workaround could be to increase TOP and BOTTOM margins to reduce the possible number of lines per page.