is there a way to turn off blue squiggl underline when writing odt. document?

The blue squiggly line under text when writing drives me nuts! Do you know how to turn it off?

Is it the “wrong spelling” indicator? If so, reset your profile because spell check is not working and every word is being flagged as misspelt. Search the forum with spell check not working for instructions.

Click the icon with the wavy line under it - it toggles “indicate spelling errors as you type”.

Correction - in LO I think the blue line is grammar check not spell check.

Thanks John:

I’ve turned off grammar check - I’ll return to writing later today.

Looks like you are correct. Good call.

Total Noob with LibreOffice and this forum, but found this post and also found on the Edit menu there is an “Edit Mode” that I clicked on and all the squiggly lines disappeared. That is a great feature as I’m designing a user key for another document and it’s not a format that would make sense so it’s nice just to get rid of all the spell checks.

Could you explain this “Edit Mode” option? I’m using 6.4.3.2 and I have no such menu item. Are you sure you’re talking about Writer?

ajlittoz, it is under Edit (as specified by the user). If you don’t know some basic things, just learn instead of posting irrelevant comments. Obviously, disabling the edit mode turns off all checks on a document. But it is not an answer to the original question.

@gabix: don’t be aggressive, nobody can pretend to know and practice 100% of any application. I work on several computers with different levels of LO. The one I used when I made my comment was outdated and had no Edit Mode. I see it now but it is disabled (and I don’t know how to activate it; is it related to form design?). Though it is disabled, I still have spell checking active.

A blue wavy line is related to grammar check (that also a basic thing). It may be simpler to disable the grammar checker.

Try Ctrl + Shift + M to toggle the edit mode. However, if it does not work, the file may be marked as read-only by the system.

@gabix: I experimented on a brand new “lorem” document and it remains desperately disabled.

Did you save the file first? Until that (or until there remain any unsaved edits), the mode won’t toggle.

OK, seen. It’s some kind of read-only lock, turning Writer into a viewer. Not very useful when editing.

I also can not create or edit .odt documents if the distracting blue squiggle underlining is active.

To turn it off, the following has always worked for me:

  1. Click the ‘Tools’ drop down menu on the top toolbar.
  2. Click ‘Options’
  3. Expand ‘Language settings’
  4. Click ‘Writing Aids’
  5. De-select ‘Check grammar as you type’
  6. Click ‘OK’
  7. Close the document.
  8. Re-open the document.