Is there an issue with the sdk download for macos?

I have tried several of the mirror sites and most never finish the download. When they do and I try to install it I get an “Image not recognized” error. Is there something I am missing?
Thanks in advance.

The Windows version downloaded correctly. Didn’t install it yet, but maybe you downloaded a version that doesn’t work for your OS.

Installed correctly. So it it’s either an issue with your computer, a wrong install file downloaded, or something wrong with the install file for Mac OS.

I think its something to do with the install file for the Mac OS. Like I said I tried several of the mirrors from around the world and they all have they all of the same issue. It either doesn’t finish downloading or I ge the image not recognized error. When I check the file info it says it has 0 bytes even though I can see it downloaded a 43MB file. Is there anyone in support a can contact about this issue?

Report at the bug tracker

Something is going on with it.

I had this same problem with SDK for Mac 6.1.3, 6.1.2, and 6.0.7, attempting to download with Chrome. In each case, the download proceeded normally to a little faster than normal, the progress bar got to 100% and then it just stopped. Each time, 15 minutes later I cancelled the download. No error, but no completion, and I was left with no file to inspect.

During the same timeframes, I was downloading the full Libreoffice packages that matched the SDK.

I was able to download SDK for Mac 6.1.2 via Safari, but the matching LibreOffice package (downloaded via Chrome) downloaded, but failed to validate for installation when I opened the disk image (.dmg file: name too long is the error.)

I did download and install LO 6.1.3, but removed it when I started downloading the 6.1.2 package. It seemed to be functioning before I removed it.

I went into archives and downloaded the sdk for 6.0.5 (the version of Libreoffice I’m currently using in production) via Safari. It downloaded and opened the .dmg, but the behavior described in all the tutorial information suggests “install the sdk” generically for all OS types. I expect either a package executable or a mac app package next to a link to applications. The 6.0.5 SDK for mac OS disk image opens to a directory view of the disk image, no install occurs. I went through the install process on Ubuntu 16.04, and compared the post install directory structure, but the directory structure isn’t clear enough where the files belong, and nothing online mentions where to place them, so it appears some install script is missing.

I should have posted my solution to this issue a while back, sorry for the delay. It turned out I had to update my mac to the lastest version of the OS other wise it wouldn’t work. I realized this after I created the bug report which looks like has been deleted or I would post the link here. I suggested they update the documentation to reflect that fact that the OS has to be upgraded but I don’t know if they ever did that.