Is there some known issues using button to execute a macro ?


Excuse me for my bad english…

I’m testing a very simple macro in Calc. I’m doing it on LO 4.0.2 (impossible to upgrade, I’m in a school and LO won’t be upgraded before next year), under Windows 7. But I tried it also with LO 4.1.2 under Debian Wheezy.
First, I’m recording very simple tasks : a backgroud-color in a cell, changing the color of the text, bold and italic, then moving right a few columns, and writing “COMMAND”. That’s all.
If I’m executing the macro, everything works fine. Using a shortcut to execute the macro is fine too. But when I try to link the macro to a button, then the macro isn’t fully working. It only changes the background color, but doesn’t format the text, and do move a few column to write “COMMAND” in a cell.

I didn’t try with AOO, but a student did (I think with AOO 3.4), and everything was OK. That’s weird, isn’t it ? Is it a known problem ?

Thank you.

No, @iGor2, it isn’t bug of LO. Maybe it’s just strangeness of specific workbook, of it format?

@JohnSUN Ok, thank you for the answer. The problem is that I don’t understand what’s wrong. I mean, the macro is working correctly, except when associated with a button.

It’s difficult to judge the reasons for the strange behavior of the office suite without example of bad macro and/or workbook. Try to ask a question on one of the national forums (Rassia). There you will be able to attach a file to the message.

Ok, I will. But on a french forum, even with my name… :slight_smile:

it’s an old issue that the ‘focus’ being set on a button impacts macro run, description, ‘not yet solved’ and trick to circumvent see: