Issue Changing Fonts in Spreadsheets Created with Other Programs After Opening with LibreOffice

I have looked for an answer to this issue but have been unsuccessful. Here is the background. I am in the process of converting documents and spreadsheets created with either Apple’s Numbers or Pages or MS Office. LO has done a great job of importing these documents. The issue is that if I select all of the cells in a spreadsheet to change the font, typically HelveticaNeuve, to Liberation Sans it seems to change the font for the cell but not the data in the cell. What I have been doing is to either select the text inside of a specific cell then select Liberation Sans or else retype the data. I feel certain that there must be some simple step I am overlooking that would select data in the cell as well.

I tried this with an old Lotus 123 sheet:
Test123.ods (11.6 KB)

  1. Select to the end of your data Ctrl+Shift+End
  2. Copy (Ctrl+C)
  3. With data still selected press Ctrl+M to remove direct formatting (assume Default cell style is Liberation Sans)
  4. With data still selected click Edit > Paste Special > Paste Special > Formats Only to return bold, colour, underline, etc

Thank you EarnestAl. That worked. That being said I did get the more conventional method to work once but have not been able to get it to update more than one cell at a time.

It probably depends on what program last edited it. In my example 123 sheet from 1998, the original file (unknown type now) was opened and saved as 123, the final column was added in Lotus 123 and that changes happily with change of font; it is just the others that don’t

I’ll say that I’m really not sure how a person could get much more conventional than @EarnestAl’s solution. It uses the most straightforward UI features. It’s very clever precisely because it is so conventional, quick, and clear, IMHO.

1 Like

Yes I agree Joshua4. EarnestAI’s post is especially nice for people like me who prefer to keep their hands on their keyboard instead of mouse. That being said the spreadsheets I create and use tend to be a little more complicated with regard to formatting and can include images.

I was playing around with Spreadsheets to determine what I was doing wrong and think I found out what I was doing wrong. When I select a cell or group of cells it does not work to make the changes in what is called the Ribbon in Excel. I need to use the sidebar.

Thank you very much Joshua4 and EarnestAl.

Might that be the difference between direct formatting and styles? If there isn’t a difference in what you are doing in the different parts of the UI, then we should look to see if there is a bug.

1 Like

Hi Joshua4. When I have a chance I will play around more with Spreadsheets in LO and report back to you or this forum.