Issue with copy/paste in Basic Macro editor

Ever since I upgraded from Fedora 33 to Fedora 35 about a month ago, when I try to copy/paste (or cut/paste) in the Macro Editor, the pasting uses what appear to be Chinese characters (or other similar-looking Asian character set?) For example:
I copied the End Sub line and pasted on the next line.

At first I thought this was a glitch in F35 somewhere, and I do believe it is likely outside or upstream of LO, but after several updates since, which replaced kf5 and the libreoffice suite packages at least once (and IIRC, 2x or more; several kernel updates too) I am still seeing the issue. I do not see the issue with any other part of the system.

Some things I tried:

  • Searching with nothing coming up that is related. (I consider this unlikely if it was an issue in LO, but maybe macros aren’t used a whole lot??)
  • Searching google, also fruitless.
  • Trying to narrow down the issue:
    — Copy/paste within a Writer document works fine.
    — Copying in Writer and pasting in Macro Editor works fine.
    — Copying in Macro Editor and pasting in Writer pastes the Chinese characters.
    — Copying in the Macro Editor and pasting in a new email in Thunderbird works (hummm…). Maybe no support (configured?) for Chinese?

This leads me to believe that the editor is using a different method for the copy function than Writer does, and the issue is with the editor code that is doing the copying [not setting a character set or font??], but not knowing anything about the internals, that’s just a guess.

So I have a few related questions:

  • Might there be a system setting somewhere that could cause such behavior, such as a font setting or maybe a pinyin alternate input method turned on when I do not need it?
  • If that’s unlikely, could someone give me a hint as to what is doing the copying in the editor, or where in the code I might be able to find it? I have never looked at LO code, but am willing to with some pointers.
  • Might this be up-stream of LO? What project would be the next that I should contact?

As always, very appreciative of any help received!



On a whim, I tried switching from Plasma / Wayland to Plasma / X11 when logging in, and this issue does not exist. It appears that there’s some issue with Wayland (which Plasma changed to its default windowing system between F33 and F35) that does not exist with X11.

I will post this as a bug wherever Wayland lives…