Italian Hyphenation package missing


in a document I have been using in the past I got the following warning at the top of the page (in yellow between the shortcut buttons and the text

"Hyphenation package missing - Please install the hyphenation package for locale “it-IT”.

What am I supposed to do? The dictionary I am using (I think) is the one supplied by Apple and I couldn’t find anything else to download. Even googling it didn’t bring up any result.

I am using on a M1 Mac with OS12.0.1


Do you save your document native, e.g. .odt, or some alien format like .doc(x)?
Has your document ever been in contact with Google Docs?

@Hrbrgr , thanks but not really ;)I have been using LO for many years now.

@ajlittoz , yes. I have seen people asking this question (but no solutions), but I don’t understand the issue. I have always used doc/x formats, especially when I have to send a file across or load it somewhere and that warning was never shown before. It has appeared for the first time quite recently and I have ignored up until now. I updated LO not long ago, but I cannot be sure of the warning was there before the latest update.

If your document was never stored in Google Docs, ignore my question. FYI, Google Docs is known for damaging .odt documents, one of the symptoms being a complaint about an hyphenation package missing (not necessarily related to document language).
Saving as .doc(x) has no reason to trigger the warning, but you lose many formatting possibilities and may bump into compatibility issues if your document is “complex” (and, here, “complex” starts as soon as you have tables or list numbering).

1 Like

Did you set your paragraphs to be hyphenated automatically? Apparently, some accident can turn hyphenation on.
To turn off hyphenation open the Sidebar, click the Styles icon, find the Default Paragraph style, right-click it and select Modify. Select the Text flow tab and under Hyphenation, untick Automatically.

Near the bottom of the window there is drop-down list, select Applied styles from it to reduce the number of styles to look at. Check other applied styles in the style pane to make sure they aren’t automatically hyphenated.
If you still have a warning then either remove direct formatting, or go through each paragraph to turn off hyphenation because direct formatting overrides styles.

Well, yes, I do have hyphenation on for that doc and has been like that for a long time (I update it from time to time). Only now has LO decided it doesn’t like it.

I was hoping it might be something simple.

There is an extension Italian Spellchecker » Extensions that provides hyphenation too but I wonder if the problem lies in the document rather than the availability of hyphenation. You could check if your current hyphenation engine still works on a new document.

1 Like

I suspect there is something in the document. A few months ago, many documents of mine were affected by this kind of mishap. Something has been damaged in the template I used. I don’t know exactly how. Looking at the XML, the language declaration in one of the styles was no longer en_US (taking this as an example only) but en. Apparently, the lack of the country was the cause. This may be also related to an update (don’t remember the release number). I didn’t experience the issue after another update. I am presently using under Fedora 35 Linux.

1 Like

Thanks. That seems to have done the trick.
Actually I am quite sure I used to have that extension, but it wasn’t there now (nor could I find it when I looked for suitable ones to solve my problem).
Anyhoo… for now the warning has gone.
For now… :smiley: