Java 8 JRE not found on macOS Mojave 10.14.4

Hi there,

I’m trying to use a Java Runtime Environment with Libre Office on my macOS Mojave 10.14.4.

I’ve installed the latest JRE Version 8 Update 211 ( ).
I’m now trying to add it to LibreOffice (LibreOffice > Preferences > Advanced > Add).

However, I can’t find the right Java folder.
I’ve looked in Library/Java/JavaVirtualMachines but it is empty.
I’ve looked in Library/Frameworks but there is no Java.

Any help? Thank you very much,


@Hrbrgr Documentation doesn’t help with this problem.There are several problem with that:

  1. Java gets installed in /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/
  2. This directory is not selectable using the LibreOffice dialog and the file selection dialog on MAC OS X, since the directory JavaAppletPlugin.plugin is considered a file due to .plugin in its name.
  3. Working around problem 2) using a link leads to a next problem that LibreOffice doesn’t recognize a JRE.

@anon73440385 thank you, nice that you have paid attention. MAC is not really my world either.


for whatever reason, the only solution I found is to install the JDK from* - see Java SE Development Kit 8u211.

After having installed the JDK, LibreOffice immediately found the JRE at: /Library/Java/JavaVirtualMachines/jdk1.8.0_211.jdk/Contents/Home/jre

Caveat: New license rules by Oracle (apply to JRE too) and may be a OTN account required (not sure about that)

Update Mi 24. Apr 12:09:08 CEST 2019

Should have read the FAQ more than once and take notice that it clearly states, that JDK is required to get a working JRE for Mac OS X. Would have saved me hours of testing and investigating.

Heh. But did you actually read the FAQ, which specifically mentions JDK?

I must say that I don’t have a mac, so couldn’t add there more than that single sentence; so if your answer actually adds value, please amend the FAQ (it’s a wiki). Thanks!

Got it - FAQ is sufficient.

I’ve had the same problem on MacOS 10.14.5 but it is now fixed. In the end I installed the jdk system and then added the link in the preferences. I suggest you do the following, as it worked for me (this is from memory so hope it is right.)

  1. Install JRE 211 as you have already done.

  2. Open Apple System Preferences. 5th row down you will see the Java icon. Open.
    Two possibilities (A) It will probably tell you to install jdk and give you a link. If there is no link you can install jdk from
    Then go back to step 2. (B) you have it installed and the Java Control Panel will appear. Open the Java tab, click View, the path is there and you can use that in step 3.

  3. Open LibreOffice Preferences → LibreOffice → Advanced.

  4. Click Add and enter the path through the normal Mac window that appears. You’ll need to go to the MacBook location in the panel and traverse from there.

Good luck!