Java JDK+JRE is not working despite multiple re-downloads and attempts

I’m having trouble using Libre Office base, it is giving multiple errors to do with my Java instillation not being found or that my JRE installation is defective (I have tried multiple times to reinstall it). In options (application preferences)>LibreOffice>Advanced, it says that “Java runtime environments (JRE) is already installed:” with the radio button for the installation pressed in.
Misc: macOS Catalina (Version 10.15.7), LibreOffice (Version

Please help,


this is a known bug #tdf135479 .

See especially comment#14, which states:

On install of Oracle Java SE 12.0.2, LO7 found 12.0.2 and worked fine.

Hope that helps.

Do you know when the bug might be fixed?
I am currently downloading Oracle Java SE 12.0.2
I Correction; Oracle is having issues with its website, do you have a working link?
II Correction; Im sorry I’m an idiot, I have it working fine, thanks for the tip

According to comment#25 a fix for 7.1.0 has been committed. Release Plan 7.1 states that the first release is planned to be releasedin Week 5 , Feb 1, 2021 - Feb 7, 2021. But you are encouraged to take a look at the bug report regularly. There might be fixes for the 7.0.x series of releases as well.