Java runtime environment and Cannot connect to database


I have installed an ORACLE JRE and when starting with Librebase - says it cannot detect a JRE
I have rebooted etc etc
Im running Windows 7 x64

When running through the wizard to set up new database - it says, cannot connect.

Please can you assist
Thank you and kind regards

Make sure that you have a 32-bit version of JRE installed. Even though you are running a 64-bit system, I believe LO wants to see the 32-bit version. Both versions can be installed on the 64-bit Windows 7 system.

There appears to be a bug in LO that sometimes the JRE is not recognized even though you have it specified properly in the options. In those ‘sometimes’ occurances, a shutdown of LO and restart usually fixes the problem.

Thanks so much. If you get a chance, please can you send me a link for the 32-bit JRE to download.

Java Downloads for All Operating Systems

Maybe is not select in Menu/Tools/Options/Advanced/Java Options - Use a java runtime environment.
Wait a bit while LibreOffice find out what are installed in the system, and select one.

I have windows 8 and Java 7 and office In Tools, Options, Advanced the Oracle Corporation JRE showed up but I guess I did not realize I had to click on it in the list box. I started base and it created a database file but could not access it because LibreOffice did not know about the JRE of the Java. I went to internet explorer and enabled Java and tested it and it worked. So, I knew Java was there and worked. I have a 64 bit system, but Oracle seems to provide the 32 bit JRE with a 64 bit JRE because some browsers use that. I noticed the path in internet explorer pointed to the “bin” folder. I tried using the Add key in Options, Advanced to point to my bin folder (C:\Program Files (x86)\Java\jre7\bin) but the path shown below the list box remained unchanged as “C:\Program Files (x86)\Java\jre7”. I closed and restarted LibreOffice and went to Base and it worked properly. It allowed me to create fields and enter data. Now I am thinking the most important part was to click on the line in the list box that indicated I had the Oracle Corporation JRE, and then saving the change using the OK button, and then getting out of LibreOffice and then launching it again. On my Windows 2000 computer I have 2 older Java JRE packages and LibreOffice listed both in Tools, Options, Advanced. I selected one, restarted LibreOffice, and was able to create a database properly.