JRE is deffective

Every time I open it prompts me with this message and I can’t use Zotero Add-on, I already installed multiple versions of JRE including 32 and 64 bit versions, I added the paths directly, checked the integrity of the packages, downgraded and upgraded LibO multiple times, nothing works, please help me, I’m currently on:

Version: (x64)
Build ID: 64390860c6cd0aca4beafafcfd84613dd9dfb63a
CPU threads: 16; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: es-MX (es_MX); UI: en-US
Calc: threaded


from my perspective the problem seems to be:

  • Zotero is a 32-bit application
  • Zotero requires a 32-bit Java JRE
  • You have installed a 64-bit LibreOffice
  • LibreOffice 64-bit runs with 64-bit JRE only (does not work with a 32-bit JRE)

Hence the solution seems to be:

  • Install a 32-bit LibreOffice
  • Install a 32-bit JRE

(Did not check on my own system)


Tested on

Version: (x86) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 1; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: de-DE, Calc: threaded

in conjunction with:


Please note

All test procedures described in my answers, are always performed using a fresh, almost unmodified, LibreOffice user profile. You may want to retry the procedure using Safe Mode of LibreOffice or after having reset your LibreOffice user profile.

Been there done that, doesn’t work : (

Just tested on my system and that works for me (need to install Zotero extension directly through Tools -> Extension Manager and need to select file Zotero_OpenOffice_Integration.oxt from directory C:\Program Files (x86)\Zotero\extensions\zoteroOpenOfficeIntegration@zotero.org\install)

This worked, any problems about running 32 bit programs in x64? tech newbie here.
UPDATE: Ok, so it worked for a an hour, now whenever I try to open it keeps sending me unending dialogs, and it crashes.