Just installed LibreOffice 5.4 and it is crashing when I load a Writer doc

Hi all

I wanted to give LibreOffice a go today and so have just installed it and am trying it for the first time. Not a good start unfortunately :frowning: When I double click a *.doc file, a window pops up which says:

“Due to an unexpected error, LibreOffice crashed. All the files you were working on will now be saved. The next time LibreOffice is launched, your files will be recovered automatically. The following files will be recovered automatically:”

I have tried uninstalling and re-installing but it made no difference. Am I doing something wrong in the installation? Is something else amiss?

I am on a fresh install of Windows 7 64-Bit, SP1. No other Windows updates applied yet.

I downloaded the installed for “Windows x86_64” OS, and I went with 5.4.4.

Any help would be great thanks,


PS - spreadsheets (.xls) seem to be opening fine.

Does it happen with all .doc files? Is this an especially complex file? What version of Word created it? How does it do with .docx? You might also try LO 6.0, which has been very stable here.

Well, I thought it was all files but I’ve just tried some more after reading this and some of them opened fine. So it is only some docs after all.

Yes, they are all .doc files, and they were created on Word from Office XP.

Complex? I’m not too sure what would count as complex to be honest. What kind of things did you have in mind?

I don’t think I have any .docx files to try unfortunately.

OK, perhaps I’ll try 6.0 and see how that goes…


Well, as per paul1149’s suggestion I just tried LO 6.0. No joy there either :frowning: After installation, when I go to open LO (or try to open a document) I am told that the program cannot start because api-ms-win-crt-runtime-| 1-1-0.dll is missing. So I’m not sure what happened there!

Not a good experience for me thus far then on LO. I really want to give it a go, and give it my support, but 5.4 won’t work for me, 6.0 won’t even get off the ground, and there’s no suggestions coming in from the forum.

So I guess it wasn’t to be unless someone can tell me what to try next…

In Windows LO6 relies on the Visual C++ 2015 redistributable program, and installs it if it’s not on the system. Did it install correctly? On one of my units VC++2015 wouldn’t run until I uninstalled all previous VC++ redistirbutables. Then I ran the LO installer again and it was fine.

Hi again Paul

Perhaps that has something to do with it… Visual C++ 2015 redistributable seemed to install fine, but looking in Control Panel > Programs and Features, the following are there as well:

Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161

Would they have been installed when I installed Windows itself? Is it safe to delete them if so?

Thanks for the help :slight_smile:

PS - is there an option in this forum for me to receive a notification (email) when someone makes a comment on a thread?

And just to add another thing… Neither 5.4.4 or 5.3.7 are working; they keep crashing. And as far as I could see they did NOT need a Microsoft Visual C++ Redistributable. So I don’t think that applies to those versions.

Plus, after quite a bit of googling, it would seem that uninstalling older versions of Microsoft Visual C++ 2008 Redistributable is considered a bad idea.

If 2105 installed correctly, then I doubt that’s it. But I did search your error, and that’s what I saw. And when I searched my 2105 not installing error, it was an MS tech who said to uninstall the previous versions. The versions are not perfectly redundant, so there is a chance you could break another prog. But I guess the thinking is the probability is low. I think they are installed with windows, because my problem occurred on a new install. More…

You could create a backup point, or better, take a system image, and try uninstalled the older VC++s. That could clear up the LO5 problem as well as the LO6, because the VC++s could be breaking each other. This makes sense if LO5 wasn’t crashing before.

To track comments, click on the red envelope to the right of your user name.

You’re very welcome. I hope you get this working. More…

If you get LO working - even by uninstalling LO 6, and then VC++2015, manually, LO has a document converter under the File menu, which may work. Or you could open the files with a more recent MS Word (the problem is probably that they were created with an old version), and save them in .docx format, then open them in LO. Lastly, there are plenty of online doc converters; I’ve never used them so I can’t judge them.