Just updated to Version and now hyperlinks in calc no longer function

When I hover over the cell with the hyperlink I can see the URL but when I click on the link it doesn’t open in my browser. Using a Mac 10.8.4. Browser is Safari.

Now default is Ctrl+Click.

You can change it in:
Menu/Tools/Options/LibreOffice/Security/Security options and warnings.

Thank you though I didn’t see “Options” in the “Tools” drop down list. I went to Menu/LibreOffice/Preferences and chose “Security” under the LibreOffice drop down menu in the left column, then clicked “Options” in the “Security options and warnings” area, and un-clicked the “Ctrl-click required to follow hyperlinks” in the “Security options” area.

Sorry I had not seen you are using Mac, where options are in a different place.