Keeping single point of reference with style, in master and style template

When starting writing in LibreOffice, use direct formatting is good. Direct result, without to learn to much. Later I used styles, in de text document itself. After that templates (.ott) documents, and now I want to use one Master document (.odm), with one template (.ott) for the master as also the multiple small text documents (.odt).

This question has similarities with and continues on the knowledge given in the answer.

Building knowledge on this way is good, fast result, and it looks good. But with large documents it is getting a burden. I do not want Direct formatting, nor direct styling in documents anymore.
Temporary style in document (.odt) is good. I can work on it, step by step, until I am satisfied. But later I want to transfer this styling to the template (.ott). That works also. But now I want to remove the styling in the .odt document, and only use the styling of the template.

I want to keep a single point of references for styling in my document. It may be good, it may be bad, but it will never be inconsistent.

I easily can remove direct styling with Ctrl-M, but that is not sufficient. I also want to remove the overide styles from the template.

How can I remove all styling from a .odt . And, before that, how can I check if a style is override?

I want to be sure my large document is consistent in style, and that is only possible with only the styles are used from the same template used for text document (.odt) and the master (.odm). And nothing else.

This comment should be places at the end, but I have no idea how to do so.

Now I get it. What I did was using the extension “Template Changer 2.0.1”. You used, the standard writer function, which is better, Menu → Styles → Load Styles. I will do so also in the future. Thanks.

If your documents are correctly templated (*), there should be no problem. When you re-open your document (.odt or .odm), Writer notices that the template has changed and asks you if you want to apply the new style definition. Press Update Styles and all styles are updated.

(*) By “correctly templated” I mean your template has been integrated to LO machinery. In other words, you didn’t double-click on the template icon to create a new document. While this gives you a document based on the template, it doesn’t link permanently the document to the template and, consequently, you don’t get the automatic style update feature.

Your template should have been save with Templates>Save as Template so that LO is aware of its existence. Since the template is moved into a “system” directory, I suggest:

  • either you add a user directory for your custom templates in Tools>Options,LibreOffice>Paths
  • or keep a copy of your custom template in some of your directories because template management will move it into the “system” directory

My preferred option is the first one.

I tried your suggestion. The style is correctly template. The style “Left Page” had, in tab “Page” property “Height” the value 240,00 mm. I did change this in the .odt to 340,00 mm. The difference was visible. So now the template style property was override by the document style. I saved the document, closed is, and reopend the document. I did not got a message to apply new style definitions. This is understandable, because the template itself did not change. The heigth does not have the template value of 240,00 mm but the override document value of 340,00 mm. Normal, this is what you want, because it is override.

But I want to use all values of the template. So revers, or delete, the document style settings. So I have a single point of reference again.So I search for a kind of CTRL-M for document styles.

My answer was valid for the case when you change the template and immediately reopen the document.

When Writer is unable to handle the “overriding” case, click on the + button with a down-pointing arrow at right of the style pane toolbar. From the drop down menu, Load Styles from Template. point hte dialog to the appropriate template either through direct selection in Templates section or with From File button. Tick all style category check boxes and, most important, Overwrite which will have the Ctrl-M-like effect you’re looking for.

Done that, and indeed the page Height was set back to 240,00 mm, the template value. That was the CTRL-M like effect I search for.

You previous suggestion was already working for me. I do not get what you mean by:

Tick all style category check boxes

The “tick all …” is a fool-proof step to make sure all styles are imported from the template and none is left aside.

Where can I find the "Tick all … " within the style Toolbox?

There is no such “tick all”. You must tick manually all check boxes (there are only 5 of them).

1 Like

I have no idea. Could you add a screenshot?

Load Styles from documents or document templates

Your reply was to short to be recognized by me as a solution. With the extra knowledge, from ajlittoz, it became clear to me. But the problem is solved by now. Thanks for your reply.