Keyboard entry for apostrophe is entering a « sign. How can I reset?

This is happening only in the LibreOffice Writer. Other applications enter normal apostrophe sign for the key. The keyboard viewer also shows apostrophe sign for the key. Using the same key with shift produces a quotation mark sign as expected of it.
LibreOffice App Version:
Platform: Mac OS Catalina 10.15.3

This is an AutoCorrect feature to automatically provide typographical quotes. You can customise or disable the feature in Tools>AutoCorrect>AutoCorrect Options, Localized Options tab. Here you can control single and double quote replacement. Set at your convenience.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Thanks. That resolved it. But I didn’t even need to change the setting, because I understood why it didn’t replace with “modifier letter apostrophe”, as this is the default in English texts, but “double angle quotation mark”, because the text was set to Hungarian. So, I just have to remember to change the text language to English when I want to write in English.