Keyboard not working in Calc

Run Libre Office Calc on Debian. See details at then end. I open an password protected file and it is displayed correctly. However, there is absolutely no response when using the keyboard. No a-Z, Ctrl, Alt or function keys etc. The mouse works though.

The keyboard works if i open Calc and create a new blank file. However, if once I open the password protected file, the keyboard is lost. Also for the previously blank file. Not even if I close the password protected file. It is still gone and only after restart it will get back.

I am not sure if it is due to the fact file is password protected or just a coincident. Anyone else having similar issues? And any solution?

Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: x11
Locale: sv-SE (sv_SE.utf8); UI: en-US
Debian package version: 1:7.0.4-4+deb11u1
Calc: threaded

Kind Regards

Please test with a file that is not keyword protected. Try all the steps each way:
With a working system:

  1. Start Calc.
  2. Open a pre-existing, unprotected Calc file.
  3. Does the keyboard respond?
    Fully recover the system, at the very least closing all LibreOffice programs by using the mouse.
    Now, with a working system:
  4. Start Calc.
  5. Open a pre-existing, password-protected Calc file.
  6. Does the keyboard respond? (I’ll guess not, here.)

If you change focus to another application (not LO), does the keyboard immediately work once that app has focus?

Have you tried changing the keyboard “language” when it is not responding…this is just a “does reset help” diagnostic.

Here are two Calc documents to try. The password is ‘mypassword’:
NoPasswordCalcDoc.ods (7.4 KB)
PasswordCalcDoc.ods (16.9 KB)

Thank’s for the test case.

  1. Does the keyboard respond?


  1. Does the keyboard respond? (I’ll guess not, here.)

Yes it actually does.

However it seems to depend on the password in use. For instance. The attached file uses password

…and will steal my keyboard once opened :confused:

Hopefully it replicate the problem for you too. Does it?

CalcWithPassWord.ods (11.6 KB)

All works as expected in Calc on Linux Mint 20. I have full keyboard control. Of course, this is a different branch of Linux from your Debian, but this really feels like something that is secondary to what it appears to be.

Have you tried the “language” change idea?

Have you just plain tried a different keyboard? I’m thinking that a stuck-key scenario or other keyboard fault could possibly be at the root of this?

Please test with a clean profile, Menu/Help/Restart in Safe Mode

Menu/Help/Restart (without any options selected) did not work.
Menu/Help/Restart (with factory reset DID work! :star_struck:
Very strange behavior, I wonder what was wrong. Anyway, problem solved. I didn’t even know there was something like “safe mode” available.


Sometimes, easily with updates, happens a corruption of the profile. Not easy to find where the issue is.

I know this thread was marked Solved. However, there really is some iffy behavior still. I thought I would add a few lines here for the record.

I do get the same issue from time to time. I have not updated LibreOffice or something, it just happens. For the moment, not even the Menu/Help//Restart does not help. Well, after a restart (even normal) I do initially get the keyboard back. I think I have only had the issue when trying to open password protected files although I am not 100% sure that is related or not. However, after filling in the pw, the documents opens successfully. But keyboard is completely dead. NumLock, Windows-key, alt+tab works but nothing else. No function keys, no numeric keyboard, no arrows, no characters/numbers/spacebar. Actually, also if I type the wrong password, same things happens; Keyboard is lost and I cannot type in another one.

I made one additional observation though. If I close the spreadsheet I get to the LibreOffice “start” page. But keyboard remains dead. I cannot tab around nor use the alt+key to access menus. Also if I open a new Writer Document (using the mouse), the keyboard is still dead! So it seams the complete LibreOffice is put into some keyboard-less state. I.e. it appears to not only be a LibreCalc issue.

Maybe this helps to trace some bug in the future.


1 Like

With all this info, would you fill a bug report? Then share the bug number here. Thanks.


I have filed a bug report here;