Keyboard shortcut reassignment for F11 not saved

I’m trying to assign F11 to enter Full Screen mode in Writer. By default F11 opens the Styles side panel. I may reassign the Styles command to another key later, but right now all I want to do is make F11 put Writer in Full Screen mode. After making the assignment and trying F11 it opens the Style side panel, and when I go back and look at the keyboard assignments, I see that my assignment was not saved. On my system the OK button in the assignment dialog is not visible by default, but I am able to move the window and press OK after making the assignment, so I’m not sure why it’s not saving. I tried assigning it both with the “LibreOffice” and the “Writer” radio button pressed. I’m using LibreOffice on Ubuntu 20.04.

P.S. It occurred to me after I asked the question that maybe it wasn’t taking because F11 was already assigned to Styles, so I reassigned Styles to ctrl+shift+S and fullscreen to F11 and pressed OK, but still no joy.

I noticed something today. When I select the View menu in Writer, it shows F11 next to Full Screen, and if I select it with the mouse, it does do to Full Screen. However, if I press F11 with the View menu open, nothing happens, and if I press F11 with no menu active, it opens the Style side panel.

I figured it out. I had set F11 to Full Screen in LibreOffice, but it was Style in Writer. When I made it Full Screen in Writer also it worked. I would have thought it wouldn’t let you assign conflicting shortcuts like that or at least warn you of a potential problem, but apparently not.

I think it is a matter of priority between configuration tables. When you’re in Writer, the Writer table is looked up first for the key combination. If it is not found, the common LibreOffice table is searched.

Consequently, if you left F11 in the Writer table, it will be found and the LibreOffice table will not be taken into consideration.

That makes sense.