Keyboard shortcuts customization issues under LO 6.3

[Running LO 6.3.2-2 on 64bit Arch linux]

[Addons: TexMaths v0.48, Zotero LO Integration v5.0, Wiki Publisher v1.2]


Hello everybody:

I just rebuilt my user profile and am a bit perplexed…

-1- I cannot find the Edit > Find menu entry in the customize keyboard window.

I tried all menu categories, and no dice. How can I give it a keyboard shortcut ?

Has anybody seen this in LO 6.3 already, or is it me needing new glasses ?

I have been at it for over an hour now.

-2- It seems I also can’t give the action “Insert > Endnote” the keyboard shortcut I want.

Unlike for Find I found the corresponding item in the customization dialog window, but if I give it CTRL-SHIFT-e as key combination, save and try it, the key combination inserts an underlined “e” where the cursor is located in the active document window. A click on the space bar makes what looks like a emoji contextual menu appears.

How can I suppress that emoji thing (I had never seen before 6.3) and get away with my key combination of choice ? (Note that other key combinations do work, eg CTRL-SHIFT-,.)

-3- I would like to issue a keyboard shortcut to the action Insert > Field > Number of Pages. How do I do that ? I did find instances of either Field or Fields in the kbd customization dialog window. I tried all, but they seem to open the Fields dialog window where field items which are NOT contained in the Insert > Field sub-menu level are listed.

Can it be done ?


[If the forum rules specify that in spite of the fact that all those issues are related to kbd shortcut customization, I should post 3 different times to ask those 3 questions. I’ll be glad to comply.]

For problem (1), in the Keyboard tab of the Customize menu, in the top right corner you need to select “LibreOffice” instead of just “Writer:” the “find” command is the same for all LibreOffice applications.

For problem (2), it seems to me that the particular shortcut you choose is being used by your desktop input method: the system has priority over any program when using keyboard shortcuts.

For problem (3), in the Function field within the keyboard shortcut dialog type “page” to find all the related options: you need the “page count” field.

Tx RGB-es for taking the time.

1) For me there is no find under LibreOffice for the “All commands” category. What I have is the same local sequence as for Writer:

  • Filter Navigation
  • Find & Replace
  • Find Record
  • First Author

  • Could the corresponding keyboard shortcut have been deprecated for that menu item ? (I’ve just seen it for the Quick-Launcher… whose disappearance was completely unexpected for me.)

2) CTRL-SHIFT-e is not a key binding I put on my box. In any case the issue (as well as all I report here since yesterday) started immediately after rebuilding my user profile. I never had anything like that before and nothing has changed except the re-built user profile. … + I have no idea where the emoji shenanigan comes from. I may be wrong on that but I don’t recall enabling or installing anything that has emoji in it, except maybe “Telegram Messenger” 3 yrs ago.

3) Perfect. Tx.

For (1), yes, for some reason it’s not shown in the command list, but if you scroll the shortcuts list until Ctrl F you’ll find it.

For (2), I think it’s a GTK thing to insert emoji, something similar to Ctrl Shift U to insert Unicode characters. In fact, none of my KDE applications use that shortcut, but LibreOffice and Firefox (the only GTK related apps I use) do.

Sorry, I had not been notified about your last comment above (maybe for lack of “@Cbhihe”).
1) Just checked that my CTRL-F is blank (not attributed in my present customization scheme under both LibreOffice and Writer.
(If you say you have it, then I may have deleted it by mistake. I just don’t remember.)
No matter the pbm remains unchanged. How do I get it back, if I can’t select it in the Category/Function customization window, because Find is not there ?

On that same subject, I just discovered that, under Tools > Customization>Toolbar pane there is the LibreOffice Scope (on right hand side) and right below, the possibility to configure the target Find. It is the Find toolbar that opens at Writer window’s bottom. Can I give it a CTRL-F shortcut that toggles it on and off and places the cursor in the find field when the toolbar is on ?
There MUST be a way…

2) I verified that CTRL-SHIFT-e does the same in FF. Good call.

@Cbhihe indeed, it’s quite strange that that command is not easy to find, maybe the problem is worth a bug report. The Revert button in the keyboard shortcut dialog reset all shortcuts to their default values, maybe that way you can recover the Ctrl F one.

I confirm that the CTRL-e keyboard shortcut is a GTK thing (for those of you who use Linux on GTK).

To get rid of that GTK default, open a terminal and run ibus-setup (on Arch) or the equivalent GUI app for your host OS. There you can pick CTRL-e out and get rid of it.
Once you’ve done that, you’re home free and your CTRL-e shortcut becomes available in LibreOffice.