Labels not printing

Using on Linux Mint I’m trying to print some mail-merged labels.
I followed the instructions (found in several places on the web e.g. ref 1) and all works as described until I press in the mailmerge window. At this point I do not get the anticipated printer dialogue window, the mailmerge window simply closes.

If I delete all the database fields and insert only static content then all proceeds normally.

If I try and mailmerge to file I get the expected ‘Save’ window but nothing is saved.

I have tried this with two different databases, one native HSQLDB and one linked to a spreadsheet with the same results, I have tried different combinations of fields to no avail.

I have also tried selecting just one record, and a different one each time to see if there is some data in a filed that is causing the issue, but again no change.

ref 1 Creating and Printing Labels and Business Cards - LibreOffice Help


It sounds as if you haven’t selected any records.

There are a couple of ways to get labels from to directions you linked to.

One way is shown in my answer on this post → Having trouble populating a table with a spread sheet. It mentions spreadsheet but the data is coming from a Base file.

A second way is when you get to step #6, select the Print icon or press Ctrl + p which brings up a message:

Your document contains address database fields.  Do you want to print a form letter?

Select Yes bringing up this screen:

Here All is pre-selected (you could also just select individual records from table shown) & if you just press OK the print dialog pops up & ready for labels to be printed.

If this answers your question please tick the :heavy_check_mark: (upper left area of answer). It helps others to know there was an accepted answer.

This is the screen I get to. As I said I have tried all/selected records/from-to, then pressed at which point the window disappears and nothing else happens. If I use static data I get the usual print dialog screen.

Try resetting your user profile → LibreOffice user profile as something may be corrupt. Be sure to follow instructions & make backup first.

Another note: Reloaded LO v5.1.6.2 on Mint 18.3 (Cinnamon) and had no problem. Labels came up same as has been for quite some time. Regardless, you should consider upgrading. V5.1 is quite old. I’m moving back to v6.0.2 for now. Is your version the one installed with Mint? If so you should upgrade to PPA version. See → Ubuntu PPA

Yes I am using the version supplied with Mint. I will try on a different build/system and see if that changes anything.