language tool java implementation

Hello everyone,
I added the extension LanguageTool, but a pop-up message states that there’s no Java implementation. I did this sudo apt install libreoffice-java-common in the terminal, but the message keeps on showing. And the Language Tool extension doesn’t work.
I’ve searching for the solution here and in some other web pages, but I couldn’t find the answer.
I hope you can help me.

You are running which operating system? Is it a Ubuntu based distribution?

Package libreoffice-java-common (on Ubuntu based systems) does not deliver the required Java Runtime (JRE) itself, but the files/functionality of LibreOffice which require an installed JRE (mainly .jar files). Therefore you need to install a JRE on your operating system.

See also FAQ

Hello Opaque,
My computer is running on Ubuntu 20.04.1 LTS. I downloaded jre 1.8.0_281 from Java webpage. Then I checked whether Java was installed by running the command $ java -version on the terminal. This was the output:
Command ‘java’ not found, but can be installed with:

sudo apt install default-jre # version 2:1.11-72, or
sudo apt install openjdk-11-jre-headless # version
sudo apt install openjdk-8-jre-headless # version 8u275-b01-0ubuntu1~20.04
sudo apt install openjdk-13-jre-headless # version 13.0.4+8-1~20.04
sudo apt install openjdk-14-jre-headless # version 14.0.2+12-1~20.04

I installed the first one: $ sudo apt install default-jre
I checked the Java version:
java -version
openjdk version “” 2020-11-04
OpenJDK Runtime Environment (build
OpenJDK 64-Bit Server VM (build, mixed mode, sharing)

I added the downloaded package in Tools >Options > LibreOffice > Advanced and now it works.

Thank you very much.

Problem solved.