Letters too close / How to make a better arrangement of characters?

I want this text to look fancier. the n and g, s and t are way too close together, let’s separate them a bit, but how?
Please help me.

image description

If set, try to disable OpenGL in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use OpenGL/Skia for all rendering and check whether that fixes your problem. Since you did neither mention your LibreOffice version nor you operating system, the real path and real value (OpenGL or Skia) may be different.

It’s Windows 10 using version and it was already deactivated, so I reactivated it which made no difference.

Sometimes the size/spacing info in the font file and the character shapes (glyphs) do not match well.

Sometimes software will take shortcuts in rendering.

I suspect that rendering in the Writer edit pane does take a few shortcuts to update the view instantly. The printout (and the print preview) should not be subject to such shortcuts.

There is a smallish preview in the print dialog, but to see things properly I use menu item File - Print preview

If that preview shows the same irregular spacing/shifted characters, I would suspect that the culprit is the font you are using. Try to use some other similar font.

I just tried a few different fonts (Arial, Calibri, Lucida Sans Unicode), all the same problem. I don’t think it’s the fonts fault. I remember once using some kind of rearranging characters option, but idk how to activate it

You added an answer to your own question. Did you solve it? “Answer” is for solutions. If it is a comment to your question or my answer, use “Add a comment” accordingly. This makes the comment follow the question/answer.

Did you look at the print preview? Is it the same there? Also try exporting to PDF and look at that (though I have seen some PDF readers suffer from similar rendering issues).

It looks pretty nice when exporting to PDF which is what matters most, but can it actually look nice when still in “raw” form?

It may be a matter of downsampling when rendering to the screen. Usually common screens have a resolution of 70-100 dpi made of discrete pixels. A character glyph (which is defined as a set of mathematical curves) must be scaled and quantized to use these pixels (and a full pixel because you can’t tell the renderer to only paint a fraction of a pixel). There are rounding effects mostly visible with small sizes.

You can tell if this is the case by using the zoom slider and displaying at 200% or 400%. If matters improve, then you’re definitely experiencing rounding effects. Don’t worry. When the document is sent to printer, printer resolution is usually 300 or 600 dpi, which is much better.

If the rendering is still ugly at high magnification, you can then try to change the pair kerning:

  • select the pair of characters to separate

  • Format>Character, Position tab

  • tune the Character spacing parameter

    Not sure about the effect of the Pair kerning check box. Tried checked and unchecked and don’t see any difference).

Note that Writer seems to add this spacing to both characters instead of managing only the inter-space (as would the Pair kerning box would suggest). If this is not satisfactory, just select the first character in the pair.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.