Liberation font is corrupted in Windows 10

After upgrading Libreoffice from 5.3.7 to 6.0.3 , Liberation fonts are corrupted because they show as a weird monospaced font.
image description

Files exist in font directory:

image description

Fonts exist in registry:

But they don’t show up in installed fonts:

image description

Unstruted font blocking (Computer Configuration\Administrative Templates\System\Mitigation Options\Untrusted Font Blocking) is set “not to block”.

What is wrong?

I have just installed a brand new Windows 10. And the first thing I did, after joining domain, was to install LibreOffice_6.0.3_Win_x86.msi
The error is still the same

I figured out the problem. A Active Directory GPO was installing a font (Spranq Eco Sans) in a weird way (executing a .bat and changing windows fonts directory permissions. That was affecting all fonts installed by LibreOffice. So, I formatted my computer and I am not applying that GPO anymore.

Thank you all!

The fonts supposedly had been removed (see bug 116581). Please uninstall and reinstall LibreOffice to get them back.

Thank you for the reply. I also tried that. No success at all.

That bug is applied in LO 6.0.4. Can you please install that one (it’s prerelease in the moment)?
Please see I used WinFontsView to verify.
But if installation fails, we could remove all non-working fonts from C:\Windows\Fonts and than reinstall LO.

I have had this happen to me too during a previous upgrade.
The LibreOffice update somehow breaks the Windows font registration system.
Normally if Windows finds a font file in the Fonts directory it will install it.
But Windows still thinks these fonts are installed, but they do not appear in the applications fonts list.

You are seeing the font substituted by LO when the specified font is not installed.

If you try to install the fonts again manually, you will end up with duplicate font files in the fonts directory.
Windows renames the new files like font_01.ttf or something.

You need to delete those font files from the font directory using a DOS window or
some other application which does not display using the Windows default font interface.
The fonts will not show there.
I used XYplorer as it just shows a straight list of font files.
That is how I also saw the duplicate numbered font files.

I think I also had to manually remove them from the Windows Registry too.
Check the registry to see if your fonts are showing there.
Delete those “phantom” entries.

So delete the font files manually, and then reinstall the fonts.
I just used the Windows Font Viewer Install button.
Fonts were installed and registered properly.

And the fonts appeared again in the application interface.

Anyway, I now keep a full back-up of the font files just iun case it happens again.
Using the Separate Install GUI to install another Windows version will create a Fonts directory which has all the font files.
You can also simply extract a Linux version installation file to get the fonts directory.
Note: cannot do this with the Window install files because all the fonts are named wrong (until installed).

Normally if Windows finds a font file in the Fonts directory it will install it

Wrong. Normally if user drags-and-drops a font into fonts directory in Windows Explorer, Windows starts the installation process. It’s the drag-and-drop in Explorer that starts the process, not the fact that a file is in the directory. Doing the same from, e.g., cmd.exe (simple copy font.ttf c:\windows\fonts) will not do what you describe.

Just tldr further seeing it starting with wrong assertion.

Thank you for the reply.
I have tried that. No success at all.

You have to clean-out the LO-created mess first, then re-install the fonts properly.
As I stated above.

I did clean-out. I kinda of figured out what is wrong. After a brand new windows installation , liberation fonts work fine. But right after joining domain, it stops working. The problem is not liberation upgrade. Somehow my Windows 10 has a problem when joining domain. I have asked Active Directory admins and they said that there is no GPO that could make that happen.