LibO upgrade always resets the Quickstart autostart flag in settings

As in title. Every time you install a new version of LibreOffice over the existing one, the Quickstart autostart flag in the settings is reset.
Is there a fix for this?

Every time you install a new version of LibreOffice…

You can select “Customized” in the LibreOffice installation routine. In the dialog “Raedy to Install the Program” you can select or deselect “Load LibreOffice X.X.X during system start-up”.

Follow installation instructions “Program”

With me:
Version: (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

I’m aware of that option, but it only set autostart for the user that is installing the update - the administrator.
It does’t set the autostart for the normal user(s).

Please try
Tools>Options>LibreOffice>General -> LibreOffice Quickstarter
remove any check mark.

Removing the checkmark disables the autostart, that has no sense.

Sorry, a translation error on my part.
Please try step 2 as indicated in the link.

First steps

And please tell us, which operating system and LibreOffice Version do you use.

Hello again,
the link provided is for the steps to submit a bug and that’s OK.
But step 2 refers to a corrupted profile. That’s definitely not the case: I have over 40 installations of LibreOffice on different machines, different users, admins and non admins, different Windows versions and there are no corrupted profiles.
The behavior I’m referring occurs on every machines and installation, even o a fresh installation.
Finally, this has to be a bug in the setup program.

Can you add a line to the computer startup files? This answer might assist, --quickstart seems to be the required option: How do I ensure that the LO GUI is minimised on startup

Hello @EarnestAl ,
the parameter you suggest is not necessary. ONCE installed the update you have the startup flag unchecked for all the users on that machine except the administrator, that is the user that performed the installation.

If you check the flag again in the user options then Quickstart normally starts, you don’t need any adjustment like the --quickstart option.

The unique issue is with the update installation routine: it always disable the quickstart for all (other) users.

I just thought that if you had startup scripts for machines on the network, that you could just add a line rather than going through the user interface.

On my PC, with SSD, opening LO first time is 7.2 seconds, next time is 3.9 seconds, that would be 3.3 seconds saving using Quickstart. I never bother turning it on, not even when I was using spinning disc drives