Libre adds an ' to field formatted to time, why & can I get rid?

I’m exporting data from a rostering system (we’re a home care company) which has start and finish time of each carer. When opening the exported data in Libreoffice Calc there is an ’ before each time (eg '03:15), even after formatting the field to time. This means I can’t use any functions until the ’ is gone. I’ve tried in Microsoft Excel and this does not happen (I don’t have regular access to Excel so can’t do my work using it). Why is the ’ there and how can I open the data in Calc without it there at all? I haven’t the time to delete each ’ from each field. Many thanks.

Can you try “Detect special numbers” checkbox? I suppose that it is not checked in your case, that needs to be in order to detect dates and times

thanks Mike, I’ll give that a try

Cheers Mike, that worked (of course!)